Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

TWiST

Howdy Gents! First time quad owner, long time tinkerer.

Recommended Posts

New user and first time quad owner. I recently got a 2000 Polaris Sportsman 500 and am really excited to start working on it! I work in IT for a living and am an experienced mechanic, so at least I am not starting at 0 haha.  Looking forward to hanging out and getting to know everybody!

Share this post


Link to post
Share on other sites


Welcome to QUADCRAZY! Experienced mechanic, cool. I'm like a B mechanic myself, maybe a little diagnostics..will do my own work on my cars and atv. 😛

Share this post


Link to post
Share on other sites

B mechanic haha, I read your profile you sound like a legit professional man, A+++!! Puts my experience to shame haha. I have been doing all my own car work for about 15 years or so, but not in a professional capacity. I did a full rebuild on a 1969 Cougar which had a 351 windsor in it, after that I had a VW cabrio but only did basic maintenance on it, after that I had an 89 cherokee laredo that I did quite a bit of work on but ended up having to retire it because CA is a hassle. Then I had a 2001 Audi S4 and did a rebuild and upgrade on it as well as all my own ECU tuning, that twin turbo v6 was a beast! I have also done a lot of work on all kinds of friends, family and GFs cars over the years.

 

Currently I have a 1999 Tahoe and a 2007 Audi A4, I am currently doing a rebuild on the A4, I have a thread all about it over on Audizine, I have been pretty active there for over a decade now. And last but not least I got my Polaris and I am pretty dam excited to get it running proper and get to ride it around! I attached a pic of the Polaris I just took the other day while I was working on the A4. It is in fantastic shape, but it has sat for a while, but in CA sitting vehicles are usually not exposed to the elements like they can be in other states (one of the only positives here these days).

 

Thanks for the invite BTW!

IMG_20190428_162223.jpg

Share this post


Link to post
Share on other sites

Welcome to Quadcrazy, you will find everything you need here to help you get that bike back to good. 

Good luck on the rebuild.  

Share this post


Link to post
Share on other sites

Thanks so much! I think I have most of the documentation I will need already (in 10 posts I will check this 1 download, but I think its one I already have). Looking forward to seeing some of the fun mods and ideas other people on the forum have come up with, I never get bored of seeing all the fun creativity!

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By colin james
      View File 2006 Polaris Sawtooth 200 & Phoenix 200 Service Manual
      This is the service manual for 2006 Polaris Sawtooth 200 & Phoenix 200 ATVs. Download all the chapters for the complete manual. 
       
      Submitter colin james Submitted 11/25/2018 Category Polaris ATV  
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By Squirrel
      Several months ago, I finally got around to fixing the bayou. Rebuilt the carb, replaced the fuel selector switch, hoses and fuel filter, and she ran great. Only had 2 minor issues since then where, at higher speeds, it acted like it was choking out when I let off the throttle.
      Lately I've noticed if I let it go for more than a week, it almost drains the battery dead trying to start. I initially thought battery, but after inspecting I found very little if not any fuel flow through the line until it starts and runs.
      I'm a little baffled and don't have much time to mess with it as most my free time right now is spent on getting my rv up and ready for hunting season in the next 3 weeks. So any help on quick diagnosis checks would be helpful. Otherwise I'll just keep starting it every 3-4 days to keep things primed until I'm done hunting.
       
      Oh, and another question on a different topic. Does anybody know what the mounting brackets on the front rack are for? I'm referring to the 2 angled metal tabs with threaded holes that are located on the left, near your knee when sitting on the quad?
       
      Sent from my SM-G950U using Tapatalk
       
       
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Ben Lennon
      Hi guys new to this forum and thought I’d jump on as I’ve just bought my first quad a Kawasaki bayou klf300c 89 model. It had starting issues when I bought it so I’ve gone thru and replaced the cdi, voltage regulator and starter solenoid aswell as rebuilt the starter motor after all this it was still free spinning on electric start so I pulled the stator cover off to find the fly wheel wasn’t spinning so replaced the one way clutch bearing put it all back together and still not engaging at all. I’m at a loss and looking for some ideas on we’re to look next to solve the problem
      cheers Ben 👍
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...