Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Billy-Magnus

Yamaha Raptor 660 Trouble in top end

Recommended Posts

So i got a used raptor 660 was running fine then parked it for an hour or so then it started having some problems. It starts and idels fine then when you give it some gas it bogs out and bacfires. So i just went through it changed the gas, oil, and hit it with some carb cleaner and its still bogging out at higher rpms. have ridden it about an hour or so to make sure things were cleaned out, still doing it, and seems to be running very hot. help?

Share this post


Link to post
Share on other sites


is their any mods done to it such as different air-filter or exhaust? tack ur plug out an tell me what the color of it is.. if it spudders at a high rpm their could be something wrong with ur carb such as a wrong jet size thats always my first guess wen problems like this occur

Share this post


Link to post
Share on other sites

Yep sounds like either one of your jets is dirty maybe. I had that problem on two different quads last week.

Share this post


Link to post
Share on other sites

for mods it has a yoshi pipe and a jet kit. spark plug is new, i took apart one of the carbs today and it looks very clean, wasent able to get into the other becuase of a stripped screw. im thinking it might have to be re-jetted because of the change in weather

Share this post


Link to post
Share on other sites


I agree with those guys, it sounds like a jetting issue since you had a jet kit and some other mods installed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • 1990 Suzuki LT 4wd need help running issue

      my atv will start right up will idle fine soon as i try to throttle up engine dies,i have changed gas,new fuel pump and lines great compression 188 lbs.new coil new spark plug adjusted valves dont know what to do also rebuilt carb,any help wanted

      By joseph, in Suzuki ATV Forum

        
      • 19 replies
      • 210 views
    • 2001 Quadrunner 500 Running Problems

      Hi all, Picked this bike up about a month ago, and started doing some work on it. I ordered a carb kit from China, but got tired of waiting for it so I went to the bike shop today and picked up a Shindy rebuild kit. Took the carb out of soak, it has been in there for a month, blew all the ports out, cleaned what I could with a guitar string, used air as best I could to make sure everything was clear. After I was satisfied the body was clean I out the kit in it. Got the floats set to 13mm as per the manual (well 12.87 on one side and 12.92 on the other, so close), set the pilot to a little less than 2 1/2 turns out (manual says 2 3/8 turns). Put everything back together and tried to start it, it started and had a week idle. I tried adjusting the idle screw and as soon as I turned it the bike died. Backed it out and tried again, same result. Left it backed out, started it again and gave it some throttle. As soon as the throttle is touch the bike dies. Changed the spark plug for a new one and checked the spark, good and really strong. I am thinking that I have a bad petcock and am not getting enough fuel to the carburetor. So when I press the throttle I am increasing air but starving for fuel, bike can't run on air alone so it dies. Does this line of thinking make sense? I am gearing up a bottle with a fuel line in it, so I can try gravity feeding fuel to the carb, just have to wait for the silicone to dry so won't be able to test till tomorrow.  If it turns out to be a bad fuel valve, I will most likely just replace it with a universal one. If I go this route, what do I need to do with the breather line off the carburetor that used to go to the OEM petcock? Block it off or leave it open? Any help, answers or other ideas of things to check would be greatly appreciated. I have a fishing trip at the end of the month and would love to have my bike running by then. 

      By Coyote251, in Suzuki ATV Forum

      • 11 replies
      • 457 views
    • 2003 Arctic Cat 400 Auto 4x4 problems

      Little history, when it would get hot it would loose power, backfire and quit. Let it sit for an hour and it would crank right up, that is why I suspect the coil is bad. It ran when I brought it home from hunting but now the starter isn’t working thus I’m thinking relay or fuse. Engine will turn over with pull start but won’t start. Also the winch solenoid just clicks but winch won’t work. I’ve replaced the rear axles, wheel bearings, brakes, ignition switch, tires carb rebuild and other stuff and I’m frustrated and tired of working on it. Any suggestions would be much appreciated.

      By Brutus25, in Arctic Cat ATV Forum

      • 2 replies
      • 103 views
    • 2013 Honda Rancher 420 starts then dies?

      I have 2013 Honda 420 4x4 FPA It will start then run for 10-30 seconds die then won't start back up for a few minutes. Let it sit & it will crank & run again for 10-30 seconds then die again. Any suggestions? Thanks  PS It was flashing codes for both the oil temp & water temp sensors I replaced them IT cleared the codes & quit flashing now it's doing this. 

      By yamaha127, in Honda ATV Forum

        
      • 4 replies
      • 421 views
    • 2006 400 starts, idles a while then quits

      My 2006 artic cat 400 will start then idle for short period of time dies. when it stops it backfires. Sprayed carb cleaner through carb and tried seafoam.

      By Don Hutches, in Arctic Cat ATV Forum

      • 4 replies
      • 303 views
  • Similar Tagged Content

    • By Matt Dyche
      Can anyone give me guidance on my issue. I have a 02 Grizzly 660 and replaced the wet clutch, primary shaft, one way bearing.  Today I was riding since I tested and was driving about 20-25 mph and all of a sudden the tires locked up, heard a screeching sound, and engine died.  Didn’t have a clue what was going on, decided to try and restart, engine turned over normal but engine hesitated slightly, started and had to assist with the throttle.  It seemed to do this for a minute then seemed to straighten out.  Got home, pull clutch cover and test drove to witness clutch operation and everything looks and sounds perfect.  Could not duplicate.  Please help. 
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • Guest Fox300exchic
      By Guest Fox300exchic
      If we had a dollar for every time the question “Which is really faster, the 700 or the 450?” shows up in our inbox, mailbox, or voicemail, we’d be putting this magazine together from a bungalow on a barely inhabited tropical isle named Quadhama.
      http://www.quadmagazine.com/quad/features/article/0,24942,1603755,00.html
    • By dyyjrr9
      I just got a 1991 Yamaha Moto 4 for my son and I am looking for a service repair manual. I know that the timing chain needs replaced.
  • Recently Browsing   0 members

    No registered users viewing this page.


×