Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

TEVANS

2007 Polaris Sportsman Check Engine Light

Recommended Posts

My 2007 Sportsmans "Check Engine" Light has recently appeared on the instrument cluster. It has 39 hours on it now and maybe 100 miles. It's been on one hunting trip and that is when I first noticed it. I was crawling in low gear. I shut it down let the fan run until it stopped and crawled back down the hill. Once I got to flat land and could open it up it was fine. This weekend, I was plowing some snow and it intermittently came on and off. Any ideas??? I do need to get it in for it's first service.

Share this post


Link to post
Share on other sites


I have renamed your thread title to include year, make, and model.

Just a thought...it sounds like it is overheating, which could cause the light to come on...:yes:

Share this post


Link to post
Share on other sites

If it is still under Warranty, I would take it back to the dealer. If not check the fluid levels. On my 09 Honda Rubicon the radiator cap was bad and had to be replaced. Have you had it in the mud or dusty conditions? If so take a garden hose and rinse the radiator out opposite of the air flow of the fan. This is also a common problem on the Sportsman line.

Share this post


Link to post
Share on other sites


Could be that your air cleaner is getting dirty also. I would be sure to mention the problem to the service techs if you plan on taking it in to have the service done.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By anryu451
      I cannot get this drum off, I already have another drum and backplate on order because I've ruined this one trying to get it off. Completely rusted to splines. I cant fit any hub or wheel puller known to mankind onto these lug studs to try and pull it off, I'm really running out of ideas.
    • By FlyingJBIRD
      I've bought a used 2007 Polaris Phoenix 200... it's in pretty good shape... but after it starts, warms up, a few minutes of my son riding around yard it will die... it refuses to start back until the next day, then same thing again... I've seen this is a problem but haven't found any real answers... my son is driving me crazy to get him back riding... any help is greatly appreciated...
    • By Gilbey
      Anyone have any good ideas to clean the gear position sensor on 2007 250 Sunl atv? Getting some false readings that it is in
      neutral...
    • By Eddie Lambert
      So I picked up a Cannibal that has been sitting for many years. I wonder if anyone can tell me where that vacuum port is on the engine. I’ve found the one to the air box, pressure regulator, and ecu but can’t seem to locate the one on the engine. Thanks in advance for any help. 

    • By Nathan Knowles
      Hey everyone! new quad guy here so I purchased a Chinese quad yes I know rookie mistake but all I wanted was just something to bomb around in.
      So I serviced it, changed the oil and filter new spark plug and cleaned the carb and topped up on gear oil and new battery but the issue is I can get it started and go but if I let off the throttle it stalls out, I have 1 or 2 vacuum hoses I can't quite figure out 
      And my 4x4 actuator doesn't engage but I haven't played around with that much yet 


  • Similar Tagged Content

    • By bradleyheathhays
      I'm going to check the valve clearance on my 2011 Grizz 700 for the first time and I'm also wanting to check the timing, but I'm not sure how to do it. What tool (light gun?) do I need for this job and how is it done?
    • By ut1w7b
      I have a 94 sportsman 400. It sat for several years before i got it. I have cleaned the carb it will start and run for about 5 min then it will flood. I have torn it down and cant see anything wrong. has anyone else ran into this problem any hel would be great.
    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By RoxanneRoseReid
      Need a polaris manual for a 1994 2 stroke 2/4x4 quad free. can you please post a link I can click on Thank you. Roxanne
    • By bodatiouskid
      Have a 2002 Polaris Sportsman 700 that only has 34mi. on a carb & ring job.
      Cut the gas off today to drain carb.Now engine will not idle.If I open throttle will run,but let off & will cut off.Can screw idle in with no change.
      What happened? Why did this happen when fuel ran out?
      Please help me,my ATV is a daily driver.
      Please help!!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...