Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

tds7

2004 Suzuki Vinson Oil Level Sight Glass

Recommended Posts

I just got a 04 Suzuki Vinson, changed the oil and done other service work. My main question is about the crankcase oil capacity, Owners manual states 3.8 quarts with filter change, but it completely fills the sight glass. It was like that before I changed the oil and filter but it had over 4 quarts of oil in it. Is it supposed to be like that?

Does anyone know if 3.8 quarts is correct and is it supposed to completely fill sight glass when it running or engine is off?

Edited by tds7

Share this post


Link to post
Share on other sites


I would feel safe trusting the manual, but if you want to be sure, call a dealership and speak with a service tech.

Share this post


Link to post
Share on other sites

Does anyone know if 3.8 quarts is correct and is it supposed to completely fill sight glass when it running or engine is off?

It's with engne off.

* Added year to your thread title.

Share this post


Link to post
Share on other sites

if it's like my 250 quadrunner there should be 2 marks on the casting on each side of the sight glass the oil level should be between the high and low marks.when warmed up and not running hope this helps

Share this post


Link to post
Share on other sites

Thanks to all,

My sight glass is completely full when engine is off and I can just see a bubble in the top of it while it is running. But I can also see the oil surging through it while it is running.

The reason I asked the question was, I also have a 03 Suzuki XL7 and their was a few incorrect fluid capacities in the owners manual. Just making sure.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JustRandy
      After looking at the wire diagram I saw the blue w/black stripe wire is coming from the neutral and reverse lights looking for ground thru the neutral and reverse switches. If it finds ground, the lights come on. The same wire also comes from the neutral relay looking for ground at the same neutral and reverse switches. So it was easy to trick the relay into thinking the engine is in neutral all the time without having the light on all the time. Just cut the blue w/black wire at the relay and ground it. Easy
      Sorry the pics aren't better




      Now it starts in any gear and indicator lights work as they should.
    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By bodon
      Anyone know what the fuse terminal marked UNSWITCH  does  .  Even with the key off it is causing a drain on my battery and I'm trying to figure out  what that terminal goes to.  It's a 10 amp fuse. If I pull it the "short" goes away.  Thanks in advance.
    • By pablo Blake
      Its in pretty rough shape and its gonna be my first atv, I worked on bikes before but nothing to do with quads. Anyways the quad has some problems and im tryna figure out what to focus on first. So the U joints i think are shot. The bike starts first try every time ussually have to give it a lil gas with the throttle and revs right up, idles fine but its running REALLY rich 3 starts and my brand new plug was pitch black

      Bike is L model

      video-1577465068.mp4

      Its using the original mikuni carb but im not the best at fixing the carbs and wondering if there is anywhere online that would be able to either walk me through it or help me with it i didnt see a air mixture screw so it seems like im gonna half to open it up and adjust like the float and a couple other things
    • By Jerry Hebert
      1985 Lt50 no spark from aftermarket coil . Are these Suzuki coil specific ??
  • Similar Tagged Content

    • By Trenton
      Hello. I am a new member as of today. I had a quick question to ask. I recently was driving mt HONDA RANCHER 2004 GPSscape 400 and my display stopped working. I was driving the atv and all of a sudden the speedometer and the service lights went out. Also the lights stopped working. I am still able to shift gears, change from 2wd to 4wd, and can still select if I want EPS or Auto. I have checked my fuse box and have changed a few of them around. It did not change anything. I was wondering if anyone had any idea of what had happend. Thank you for your time- Trenton 
    • Guest
      By Guest
      Ok...I'm gettin' me juevos ready to do an oir filter clean....
      Went to my local harley/quad dealer and he had me purchase the No-Toil kit (Cleaner, Air Filter Oil, Rim Grease)
      What I've read is that the No-Toil cleaner will NOT clean
      other oils off air filters....just the No-Toil oil....
      So, I've also read that others have cleaned their air filters
      in the kitchen sink, used gasoline, or used flash solvent....
      Looking for advice as I've mentioned I'm very mechanically
      DECLINED!
      I'm going to wash the air box seal in the sink and give it a good dry....
      One more thing......No-Toil or Bel-Ray for filter oil?
      Thanks!
      -TD
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...