Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2001 Polaris Scrambler 500 4x4


casper_sr_00
 Share

Recommended Posts

i have a scrambler 500 4x4 its a 2001 for some reason all the lights,fan and the four wheel drive stopped working im not sure if there are any fuses on it but i cant seem to find them anywhere all the wires look good that i can see not sure what to do. Anyone with this problem? does anyone know if this four wheeler has any fuse if so please let me know [email protected] thats my email thanks Chris

Link to comment
Share on other sites

Dream Car Giveaway

If you have a multi-meter, get it out and start checking for lost power. Start at the battery and trace each circuit back toward the problem area and see where you lose power. Chances are that a primary circuit, responsible for powering all off the things you are having problems with has failed. Could be a fuse, could be a shorted wire, could be a loose or corroded connection or ground. If you don't have a manual, get one, they are a must have IMO.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...