Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Polaris xpress 300 grinding when going into any gear


tkokenos
 Share

Recommended Posts

I just recently purchased a Polaris xpress 300 and have had a number of problems.. I purchased it in none running condition and found that it needed a top end done.. after completing the top end and not being able to find the oil drain plug for the engine, any kind of dip stick to check the oil, or any where that I could fill the engine with oil I was already frustated enough.. and then when i finally did get it started and tried to put it in gear and it would just grind(no matter what gear) My frustation has become monumental.. any help with this problem would be greatly appreciated.. i've already tried to idle the engine down to it nearly stauling out and then tried putting it in gear and it would just grind, or if i tried to force it it would just staul out completely.. for fear of tearing up gears I would like some input procede any further..

Thomas,

Link to comment
Share on other sites

i have had several of the polaris quads and have had problems with them ... you should check to see if the belt is to tight and also if it isint then check to see if the clutch is grabbing and or draging ... if the rear pully on the belt system is turning while in idle then it will grind when trying to put it in gear ...

Link to comment
Share on other sites

The transmission problem sounds like the silent chain inside the trans its something I have repaired on several its not hard but the trans has to be removed and cost about 60.00 to replace. Ajusting the rod might get you forward or reverse but not both.

I bought one last week with the same problem........ Polarisatvrepair.com Todd

Link to comment
Share on other sites

  • 10 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...