Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

hangingon

newbie from Georgia

Recommended Posts





Hot and dry. I just heard of a place to go ride near me it called treat mountain I want to go check it out. There is a few video's on you tube I watched it's 3 to 4000 acres by what I'm told. It's free and not a pay to ride park. Thanks for getting in touch with me.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By madstuff33
      hiya, im not really new to riding quads but i am new to owning my own (working) quad. i have a falcon 150, which isnt too bad, bit sluggish on steep inclines but overall far better than the smc r100 i used to own. i have a basic understanding of single cylinder bikes and a less than useful understanding of anything bigger so i may be asking for a lot of help lol. anyway, i look forward to being proved wrong relentlessly and actually maintaining a working bike
    • By Serrowell49
      Hey all names Sean just joined up. I surfed the forums and couldn't track down anything to help me. Problem I'm having is when I try to start the quad with the electric start it turns over and will cough and a little puff of white smoke comes out of the exhaust. I pull started it the other day and she fired and would go for a bit if I feathers the throttle. As soon ad I would pull the clutch in though she dies. I changed spark plug, oil, starter solenoid. Haven't been able to check compression. Was thinking maybe timing is off? I'm not sure at this point I'm frustrated but keeping hope someone out here can point me in the right direction, this is my first quad.
    • By dybamx
      Hi, I am a new guy to the forum with just a little experience riding atvs.I have a 94(I think) 4x4 Timberwolf and I need to replace the ujoints on the front driveshaft. I broke one of the yokes and have found a couple on ebay.
      Is there a way to get the yokes off with the ujoints in place or is there a trick to take the ujoints apart with the driveshaft in place? I have replaced many ujoints on cars but never on an atv and I am confused on how to go about it.
      any pointers are much appreciated
    • By hangingon
      We have a mud bog near Waco, Ga that has opened and they have a atv / utv night. I hope to go watch one weekend.
    • By oerytb
      Hi everyone
      Just wanted to say a quick hello and introduce myself. My name's Oren, I'm 35, and love going out riding when I get the time. I am currently remodeling it, I ride a 1993 Yamaha Kodiak 400 4X4 that I absolutely love.
      I found this site one night trying to look up stuff on my Kodiak and decided wth might as well join. While I'm not the greatest at posting, I do try to check in every couple days or so to see whats going on.
      Anyways I look forward to learning more about our quads here.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...