Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

BuckBilly

Eiger being replaced .

Recommended Posts

I herd through the grape vine, that the Eiger is being is being replaced by a 400 King Quad. Also herd it will be in automatic and 5 speed models. What Suzuki rumors have you herd.

Share this post


Link to post
Share on other sites


Wow, I can see them doing that because there is really no need for 2 400CC utilities. I want to see if they come out with the king quad 800!

Share this post


Link to post
Share on other sites

From what I have heard the Biggest King Quad will be a 750 with improvements over the 700 King Quad.

Share this post


Link to post
Share on other sites


The 400 KingQuad is a Eiger with new plastics. I don't know yet if there is any improvements to go along with the new looks. I will try to keep everyone informed as I find out more info.

Share this post


Link to post
Share on other sites
Ooh...I guess it is a 750! Thanks for posting that pic!
No thanks needed just doing my duty as a member!:biggrin: Also it is fun sharing information with my fellow ATVers.

Share this post


Link to post
Share on other sites
The Eiger was not replaced, just rebodied. I was hopping it wquld be an improvement not just look purdier.

Yeah I belive it's just new plastic....:mad:

Share this post


Link to post
Share on other sites


I just wanted to state, that I think the Eiger is a great Quad. Just wish they would have up graded it, to compete with the 420 Rancher, 400 Outlander, 400 Big Bear and the 400 Sportsman. Still like the fact that the 400 King Quad can be had with a five speed.:biggrin:

Share this post


Link to post
Share on other sites

Eiger didn't sound that good anyway. I have a friend that has one and had a lot of trouble out of it. Some kind of electrical thing.

Share this post


Link to post
Share on other sites
Eiger didn't sound that good anyway. I have a friend that has one and had a lot of trouble out of it. Some kind of electrical thing.
I herd that before. I know 4 people who own them with less problems than the rancers their kids have.Every manufactor sells lemons. Never know what you will get.

Share this post


Link to post
Share on other sites

eigers are great.

add a g to the begining and you have my last name!

hahaha thats why i like em. :twitsy:

o yeah and ive always wanted to use this. :aargh:

haha that was fun.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Eljefe
      I have an 04 Eiger semi auto 4x4. Bought it used. It has good compression and spark, put a brand new OEM carb and manifold on it, new spark plug and did the Raptor 660 petcock retrofit and capped off the carb. So.....here is the question: I turn the fuel on, turn choke on and it fires right up and idles great. I wait 1-2 minutes and go to turn choke off and it stalls. I then leave the choke off and it fires right up and runs great all day and starts right up without needing choked the rest of the day. So why does it die when I turn the choke off?!!!
    • By caperman
      New to the forum and would like to say "Hi " to all the members. Was wondering if anyone out there has a link to a service manual for a 2007 Kingquad Eiger 400 automatic. Really appreciate any help. Thanks
    • By Eljefe
      I need help/ideas please! I have an 04 Eiger 5 speed. Runs great and pull starts. Only clicks at the solenoid when trying the electric start. Replaced connections, solenoid and starter!! Battery charged, still just clicks at solenoid!!! All lights work, I'm at a loss. Could it be the neutral relay? Anyway to test that? All fuses are good. Very frustrated.
  • Recently Browsing   0 members

    No registered users viewing this page.


×