Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2005 Arctic Cat 500LE winch quit after storage


data89
 Share

Recommended Posts

:huh:I left my Cat sit for several months while I visited the "States" for summer in WI. Battery had been removed. When I got back here to Panama and on the road again, I occasioned to find that the winch was non-responsive. Now, we have quite a bit of humidity here during the rainy season (it was doubly covered with tarps) and I'm guessing corrosion of contacts or wires.

I've cleaned all the connections, except the rocker switch and solenoid are sealed. No luck. Shouldn't I be able to run 12v directly to either the large diameter blue or yellow wire on the winch and see if the winch itself works? I got spark, but no function.

2nd question: I have an 8 post solenoid and I know the part # is 0409-066 and it is a Warn winch made for Arctic cat, but, I cannot find a model number on the winch so I can look up a wiring diagram. Can anyone possibly tell me which model winch I likely have? 2005 500LE automatic Arctic Cat. Or which winches use the 8 post solenoid? I have not been able to find any diagram of Warn winches that use an 8 post solenoid (lots of winch diagrams are available).:skeptic:

Link to comment
Share on other sites

Just a safety sticker on the end, a sticker on top saying "Warn, made for Arctic Cat". I'll have to remove the winch. I'll get back to you.

Well, before I got that far, I decided to jump 12v to the winch posts. Now, my battery is apparently dead and won't take a charge. I don't see how a perfectly good battery could have been effected. The pull start works, but even after running for 20 minutes I can't even blow my horn very well and the lcd display gets all scrambled when pulling on the hand brake lever or blowing the horn, etc.

So it's either not holding a charge or the charging system isn't working.

I will get the battery tested and see.

Edited by data89
subsequent event
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...