Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

William Sims

2005 Arctic Cat 400 CDI box

Recommended Posts



Are you looking at some online that are used? Whenever a question like this comes up, it's difficult to answer unless you have someone who has gone through the same thing. I usually suggest you look at parts manuals or OEM arctic cat websites and start comparing part numbers for various models and years to see if they match.

  • Like 1

Share this post


Link to post
Share on other sites

A good place to do that is countrycat.com. You can bring up a parts diagram for your machine to get the OEM number of the CDI Box and then compare different years for a match. Its always best to go by the OEM number of the part to cross reference.

Mike

 

  • Like 2

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By schef
      I have a DS 650x available.  Garage kept for its entire life and runs well.  OMF beadlocked wheels.  Located in San Antonio Texas area.  I’m motivated to sell and work with shipping options but serious inquiries only interested in a large sport ATV that won’t come around again.
      Here’s a photo from a few weeks ago.  I can send over more photos, videos, or we can have a FaceTime session to take a look remotely.  Let me know.
      David

    • By John conway
      My quad will start sometimes than just die well it’s running than won’t start again for a day , put in new battery same problem and it seems to drain battery any help would be great
    • By w_r_e
      Well, after tinkering on my last project (a 2003 Kawasaki Bayou 300) I ended up putting it on Craigslist and it sold within a day. Then about two weeks after that a 2005 Mule 610 with 40 hours on it popped up, for about 1/3 the cost I usually see them, so... I didn't have much of a choice.
      The Mule's first issue was idle, it would die if you didn't keep a light toe on the accelerator. Turns out the idle screw had never been touched, five minutes after I got it off the trailer it idles just fine. 🤦‍♂️
      As of today, it runs great on flat land. And it climbs like, well, a mule.
      But it has one issue. Sometimes uphill it will suddenly lose power like the fuel isn't getting delivered. It never dies completely, it just sputters and won't go until you let off the gas pedal and let it recover. It tends to do it more with 2 passengers or some cargo and wide open throttle BUT occasionally will do it at only partial throttle and with just me on it. 
      I read a lot about how the fuel pumps on these Mule 610's suck, so I put in a new one today and a new fuel filter. It still had the same symptoms immediately after, so that was $40 wasted.
      Any ideas? I keep seeing folks saying they replaced the pulse pump with an electric fuel pump. This thread said so, and it gets brought up in this thread and also here. In each case somebody says "12v fuel pump solved my problem!" and then they promptly disappear from ever posting again, lol.
      I have some questions for y'all:
      1. Do you think fuel delivery is the problem? I have a hunch that it is, given the hill + throttle symptoms.
      2. The pulse pump on the Mule is located ABOVE the gas tank. Can an electric fuel pump pull fuel UP in this manner?
      3. What would I do with the spare line that goes from the fuel pump to the crankcase? Every electrical pump is just in & out, they don't have that third line...
      4. Any idea what kind of flow rate I would need or which pump works for this application?
       
    • By Cj Winds
      I have a 2005 Yamaha Kodiak 400 Automatic. It has an oil leak inside clutch cover. The middle gear has two oil seals, the front seal is leaking engine oil into clutch area. How do you change the leaking seal?
    • By hornythrony
      Does anyone know ways to regulate the speed etc other then the throttle screw? I have turn it almost all the way and it won't move on hills but keeps getting faster on flat gravel roads. I have a Chinese quad that's bigger but is a 3 gear so I just put it in first and let my kids go nuts cuz it might rattle it self to S... but it only goes so fast
  • Similar Tagged Content

    • By Brent Mason
      IMG_4272.MOV Originally had my griz600 stop running and then wouldn’t start ! After testing all coils , valve lash , compression (115psi) and all tested ok I bought a used cdi . After cdi install it still wouldn’t start (no spark) ! So even though the stator , pulse/trigger and charge coils check within good range I decided to switch the stator etc ! It started but It is very unresponsive on throttle and acts like it is running in 2 Different spark timing ! With slight throttle it will take off good but instantly go into a very different running mode with no power like timing very retarded but it will switch back to running good for short period then bad again !  Since I replaced the stator and it started I then decided to install the cdi I replaced and it did the same thing ! Also I noticed the Used cdi I Took off had a capacitor that had swelled and extruded from the back of the cdi . I had always heard and I believed that when these CDIs go bad they machine will quit and will not run . Is that true ? I also checked the cam/valve timing and its ok ! Checked with timing light and it does fluctuate on idle ! I am thinking I have 2 bad CDIs . I also switched the trigger Coil wires and would not start then . Man , this thing ran good before and I am confused ! Video below may help !
      IMG_4272.MOV
    • By Brent Mason
      1998 Grizzly600 ! Slowly died then wouldn’t start ! All coils check good ohms ! Checked ac voltage from source coil get OL ! Is the source coil bad ? 
    • By Arnold Schimberg
      Hi Guys
      I have 88 4trax FW , it has a booster circuit
      In the cdi control fed from a leg in the alternator. 
      MY Honda service manual says you will get no spark without this circuit on this model. 
      Can someone explain a little about this please ?    Thanks
    • By Duane Steward
      I purchased a CDI box from Ebay that was listed as the one for a 200trx with round plug.....when I plugged it in the reverse light stays on.....what did I do wrong ? or is it just a bad CDI box?
    • By Joseph Miller
      Hi guys im new here and ive been doing alot of research on my polaris predator i was wondering if anyone on here has wired a different cdi up on there quad? Not a direct replacement that would simply just plug in. I know my white an w/red wires go to my pulsar my green an blue go to my reverse coil but im unsure which is + and which is ground also brown/w is a ground correct? What about purple? Black goes to my kill switch and red is my 12v supply........then ive got yelloww/red , yellow / yellow that goes to my rectifier..........any input on this subject is greatly appreciated thank you all
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...