Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

pfdloe

2003 Yamaha Warrior 350 Engine Misfire

Recommended Posts

I have the same problem on my 2003 WARRIOR, working on it right now... It runs OK on idle but as soon as I give it a little trottel it missfire badly..

Checked the carb/inlet and new spark plug. The spark is a little weak...

Share this post


Link to post
Share on other sites


Did you take the carb apart and clean it? Has it been sitting for a while? Have you tried a new spark plug? You may want to test the ignition components, stator, coil, cdi, and check to make sure you have a good connection between the coil wire and plug boot.

Share this post


Link to post
Share on other sites

I had that same problem, its a dead man switch! I had to replace my switch after i rolled my 2003 Warrior 350. 42$ later it fixed the problem. I was thinking it was a clogged jet, but had my wifes dad look at he (an atv and car mechanic) if you take the top switch on the left side of the handle bar, cut it and uncross the wires it will run fine. If you have it running fine, for craps and giggles, apply your parking brake and then try and hit the throttle, it does the same thing! It prevents you from riding the quad under those circumstances. Like I said before mine did the same thing, the motor sounds like it cuts out constantly, but never dies, idles fine all day but just doesn't run like it should.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By caperwing
      The quad starts good and runs good if the choke is on just a little. I installed a carb kit and backed the screw out 13/4 turns to where it was . Any ideas?
      Thanks
    • By johncb
      The needle sticks in the seat after setting for a day or 2 is there anything that can be done to keep this from happening besides shutting off the fuel and running the bowl empty before shutting the machine off.
    • By Zach Jump
      Hello...first post.
      Have a problem I have not been able to figure out.  
      While back the fuel pump went out...replaced it.  I got maybe 30 minutes..maybe less before the new one went out.
      Replaced it again...same thing. Now I am sitting with two more new fuel pumps in reserve but do not want to experiment and blow out another until I have a clue of what could be wrong.
      Have checked electrical...seems to be fine but I am no expert. Also the fuse is just fine.
    • By Michael Trinity
      Hey there.  I have a problem with finding the rite sparkplug for my 2007 xtreme typhoon 125cc.  No one or place has been able to find the right spark plug for it.  Im hoping someone here may have an idea or can point me in the right direction of where to find one.  The old one said ac 108 and one guy at an auto parts store said it was a 10mm spark plug.  Dont know if that was rite or not.  Also if anyone knows of a website i can download the manual for it, that would be very helpful as well. 
    • By Aaron Skinner
      Hi All...
      ok ive brought my son a Apache 100cc quad bike ans it seems to have a spark issue..
      When i got it i couldnt get a spark then i messed around with it and got a spark and got it running, then it just died after 30 mins, now no spark so i replaced spark plug, ignition coil, cdi, ignition switch, stator and regulator and got a spark again now its gone again? 
      Ive check the wiring to see if any loose connectors, cant start by electric start because the starter clutch is broken so can only kick start it and thats a pain as it sometimes slips ( needs new teeth on it)
      the kill switch us 2 wires that are just loose no switch anymore as it broken and the other wires i think are for the lights and the electric start lever which is now broke
      Im crap with electrics so not sure how to trace and test
      also my new stator has 6 wires instead of 5 so i am unsure how to wire it, see pictures of mine the correct one and the other off ebay which they say to re-wire
      any help with this guys?



  • Similar Tagged Content

    • By Chayse Hill
      I have a 2003 LTZ 400 that i bought a few days ago. The quad was running fine until last night. I let my brother ride it down the street and back and i didnt notice anything etong with bike. Then my neighbors friend came over and said "can i ride it?" I said "sure" so he ripped it down the road all fine and when he got back it died right in front of us. My brother said it was dieing on him also. He also said that he wasnt using the clutch to shift. I told him he was an idiot. Im throwing that in there incase that caused a problem as well. But today i go to check it to make sure its getting fuel which it is and replaced the spark plug incase it wasnt getting spark but it is. So i started it and it was having a problem starting then i got started and was reving at idle high. So i took it around the block and it died on me a little bit down, so i try to restart it and it started so i kicked it into 1st and it kinda launched on me and started going with the clutch all the way in. Then it died right after and wasnt running right during that process and was idleing all over the place and just died and now i cant get it started it again. Before it would start without the choke or priming it. It would start real quick now i cant figure if it needs to be rejetted or something else. Air filter looks clean also. But any help would be gratelly appreciated!
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By dyyjrr9
      I just got a 1991 Yamaha Moto 4 for my son and I am looking for a service repair manual. I know that the timing chain needs replaced.
    • By alexcross324
      Hi all, I try to find this manual in the threads but you have a lot of stock here
      Cannot find this particular manual.
      I found it for YFM200 but not sure if they are the same.
      Thanks if you could help me with that.
      Im new here so if I did something wrong, please tell me.
    • By davidwestfall
      looking for direct shift shifting lever that properly fits my 2003 Yamaha warrior 350 and fits my foot the same as a stock 2003 Yamaha warrior 350 shifting lever fits my foot
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...