Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

quadnut20

Snow in Colorado

Recommended Posts

We got hit on Tuesday with 8" of wet snow ! Hope you guy have better luck than I did:aargh:

Snow10-27-11001.jpg

Snow10-27-11002.jpg

Snow10-27-11003.jpg

Snow10-27-11004.jpg

Snow10-27-11005.jpg

1 1/2 Days with no power ! It ripped the line off my house !! :no:

Share this post


Link to post
Share on other sites


Did you touch it to make sure?

How much snow you get. looks like 6". Is this the norm in Colorado?

Nevermind saw the caption on top of the first pic! 8"

Edited by marioweldinginc

Share this post


Link to post
Share on other sites

I've gone outside 4 times to knock the branches on a tree in front of the house that the power line and cable come in from. Goes through the branches. We have about 7 inches of wet snow now and it's not letting up.

Share this post


Link to post
Share on other sites


Damn it !! :aargh: .... all I had the 29th is warm weather ... and all weekend too !! ....... CRAP !!! ......... suppose to get some snow up high tomorrow ...... but I think they're lying to me !! :bs:

But I have my tracks ready ........ SO LET IT SNOW !! :woot: ... :cheer: ... :partyc:

...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Erik Plug
      Hi all,
       
      Picked up my first Brute Force yesterday. What should have been an awesome afternoon of riding turn a bit into a deception. As I was unable to really take it out for a test drive at the shop, I decided to buy it and agreed that I would take the test drive at home. 
      When giving full throttle I noticed that the Brute was choking and lost all of its powers. Faulty fuel pump most likely. 
      Called the shop and the are coming to pick it up and repair it and bring it back. Good service. Nevertheless feels a bit sour in the mouth as I was told it was a 100% good. 
      Need to have some patience I now before I can really start riding. 
      Cheers,
      Erik
    • By Chase Cook
      Hi I was riding my Honda the other day and I gave it gas for about a quarter-mile just flooring it and then it started to lose power. I pushed it about a mile home which was a pain in the butt but when I got home It still had gas, compression and spark. Do you think the timing jumped possibly?
    • By Dan Ellsweig
      Greetings
      I have a 98 Polaris Magnum 425. Runs GREAT for 10 minutes then starts to load up (sounds rich) and looses power. Final;ly just stalls out on idle. If it sits 20 minutes will run again.

      replaced fuel, added fuel treatment (seafoam), Replaced plug (carbon fouled), plug wires, air and fuel filter, checked all fuel and vac hoses, REPLACED carb with new. Still no good. Just ordered a coil, not sure if that will help
      Note: both the new and old carb only had the idel adjuster screw - cant find the jet adjustments or air/fuel mix screws so I cannot say how they are set.

      Looking for ideas short of spending big $$ on Polaris service

      HELP?????

      Thanks

      Dan
    • By Michael France
      I have a Kawasaki Bayou 220 KLF220A and I cannot get it to start using the starter button. I have replaced the starter solenoid and the starter relay. I have followed the wiring diagram in the repair manual and it looks like the switch is working well, the neutral and reverse relay have power running through them and appear tp be working correctly. However, I can not find a wire runnng the the starter button that has power on it. Anybody have any idea what the break down is?
  • Similar Tagged Content

    • By Jeffrey Runey
      I couldn't find a thread on this.
      I own a 2017 sportsman 570 with a plow, I have a 750 foot long gravel driveway. We get a lot of snow, the plow doesn't cut it. I'm looking for some advice on atv snowblowers. Thanks
    • By Ajmboy
      So we are almost a month into winter and I've been so busy working on my house that up until today, I didn't realize that we just haven;t gotten any real snow yet to warrant putting the plow on my grizzly. So that got me thinking, what are the latest plows out there and what ATV plows are the best? I've got 2 snow plows for my grizzly, a quadboss pile driver atv plow set up and a snowsport ATV plow. They are both a bit dated now and I tend to stick with the snowsport due to ease of use and I just like it so much. So if you have a plow on your ATV, please let us know what it is and post a picture with your atv/plow would be awesome. Would also like to know what you like and dislike about it.
      This is back a while when I did a write up on these 2 plows.... in 2009 I got the snowsport and in 2012 I got the quadboss.
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...