Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Went on a SWEET Sun ride !! Had 9 friends join me :yes:Temps in the mid 40`s sunny all day !!

717ride11-20-11001.jpg

717ride11-20-11006.jpg

717ride11-20-11002.jpg

109_0291.jpg

717ride11-20-11011.jpg

717ride11-20-11008.jpg

717ride11-20-11007.jpg

Here`s Willpop recieving his princess award for the only one to crash and burn

717ride11-20-11013.jpg

717ride11-20-11010.jpg

ate like a king when we got back !! ribs and steak

717ride11-20-11014.jpg

Share this post


Link to post
Share on other sites


Looks like a great time Quadnut guy !! :partyc:

Can't believe you guys don't have more snow ... :shock2:

Where's this at ?? It looks like the country around Woodland when I was stationed at Ft Carson, Colorado Springs .... :woot:

Anyway ... THANKS fer shar'in .... :cheers2c:

...

Share this post


Link to post
Share on other sites
Looks like a great time Quadnut guy !! :partyc:

Can't believe you guys don't have more snow ... :shock2:

Where's this at ?? It looks like the country around Woodland when I was stationed at Ft Carson, Colorado Springs .... :woot:

Anyway ... THANKS fer shar'in .... :cheers2c:

...

Dead on Gunny Woodland park 717 trail system near HY 67 just below rainbowFalls !!

Share this post


Link to post
Share on other sites


Dead on Gunny Woodland park 717 trail system near HY 67 just below rainbowFalls !!

:woot:

I was at Ft Carson in 75-77 :yes:

2003 thru 2004 ....then I was shipped to Ft Bliss, El Paso, TX ... :ack2c: ... :cuss:c

...

Share this post


Link to post
Share on other sites

wish we had mountain trails here ... it looked like a blast ....we have had alot of rain here and most of the areas we ride are under water ...<<<it sucks ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Got my Yamaha Grizzly buttoned up finally and went for a quick 2 hour ride in the power lines with my neighbor, who has a Yamaha Kodiak. We have access from his yard, which is nice. Was a beautiful day today to get out and will try to go more often. Ran into two other quad riders with a sportsman and I think grizzly. Also ran into a dirt bike rider. 😎




       
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Ed Zeppeli
      Hi,
      Oddly I'm having  a hard time ordering front brake shoes for my '98. 
      I'd appreciate recommendations on decent, widely available shoes if possible. Ideally available in Canada on short notice.
       
      Thanks much,
       
      Warren
    • By hornythrony
      Hey I have a 07 king 700 there's lots of times that the quad will stall when the fan turns on also have to bump motor 2 or 3 times before starting to start it (makes fuel pump go on 2/3 times) anyone having or had this issue?
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...