Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

chevy2008

1997 Polaris Magnum 6x6 425 - Back Fires When Throttle It Fast & Idles Too High

Recommended Posts

Just bought this for 1200 and it back fires when u really give it gas or rev it up n nuetral....can smell gas like its getting to much....would this cause this to back fire? what could it b

Share this post


Link to post
Share on other sites


dirty carb. float is sticking or debris in jets. try some carb spray while it is running and see if that clears it out. if not, you may have to tear the carb down and clean it manually...

Share this post


Link to post
Share on other sites

thanks...also i dont need to choke it to start it..seeems strange to me...ans it ideal high and wont ideal down...so you think its carb issues?

Share this post


Link to post
Share on other sites


1996 polaris magnum 6x6  misfires and dies no power just got it worked fine when i bought it ... just got it home any suggestions?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By RoxanneRoseReid
      Need a polaris manual for a 1994 2 stroke 2/4x4 quad free. can you please post a link I can click on Thank you. Roxanne
    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By Weldingrod47
      Trying to change front wheel bearings. I removed the cotter pin and castle nut. Hub won't budge. Is there an additional retaining clip? Seems to be one of those push on type that barbs on the thread of the spindle. How do I remove it?
    • By warkcol
      I am having an issue where it sounds like the gears are slipping if I hit the throttle really hard and also after letting off when the engine brake is applied. Also, the drive train that goes to the front also rides again the gear shift box. I will attach pictures and a video here shortly.
      Thanks in advance!
      [ame]
      [/ame]https://postimg.org/image/cdlu6fza9/
    • By Racer944
      Hi Folks;
      Has anybody on here installed a winch on a 2003 Magnum 2x4? I am using a Cycle Country adapter plate (only one I could find), but am having a bit of trouble getting it all to fit properly, and am looking for someone that may have done this install and/or may have some pics of the installation.
      Thanks!
      Eric
  • Recently Browsing   0 members

    No registered users viewing this page.


×