Quantcast
Jump to content

Search the Community

Showing results for tags ' 425'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Discussion
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • ATV Tires and Rims
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturer Specific
    • ATV Forums By Brand
  • UTV Side x Side Manufacturer Specific
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles
    • Kids ATVs and Youth Off-Road
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Water, Snow & Other Powersports
  • QUADCRAZY Classifieds
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Lets ride Michigan trails this season!
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Up coming season
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Videos
  • Ride Red's Ride Red Forum
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads
  • Mechanics Club's Topics

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports
  • ATV and UTV Vendors

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

miles from

About Me


My Garage

Found 10 results

  1. Just bought this for 1200 and it back fires when u really give it gas or rev it up n nuetral....can smell gas like its getting to much....would this cause this to back fire? what could it b
  2. My 1995, 425 magnum has a " whinning " sound when accelerating. Does not make the noise at idle or when reving the engine. Only when its moving. Is this normal ?
  3. I have a 1995 Magnum 425 4x4 which I purchased new. It has low mileage as it was used around farm until replaced by Ranger five years ago:biggrin: now my 11 year old son wants to upgrade from his Sportsman 90 and since the 425 is not used I let him have it as his since he puts many hours in the Ranger on the farm. Prior to parking it I was having issues with it going from reverse to forward. It will not fully engage and just click. I adjusted the linkage and it would go in forward fine but then not in reverse. If I adjust to go into reverse it then will not engage fully in forward. I do not mind putting some money in this machine for my son but have no idea what part may be worn out. Thanks for any help in advance.
  4. I recently bought a Polaris 95' Magnum 425 4x4 and when i bought it went into gear with a good shove (Automatic ) anyways now it wont go into Hi,Lo, or R. I hear it click when i forcefully put it into gear but wont move. Also i wanna note that after a week of having it (never offroaded wit it yet only because the rear was loose and i had to replace bushing to keep it from shaking) That it went foward in Hi,LO, N, and R than just wouldnt go back into gear after that. Any ideas?
  5. I've been reading through these forums for about two weeks looking into the issue I am having with my 425 Magnum and have tried everything I have seen but nothing has fixed my issue. Basically, I picked this 4wheeler up knowing it would idle perfect but would not rev past 1/3 throttle. I figured it was a Carb issue but after looking at that realize it is not. I have replaced the Cam and Rockers, again not the problem. I finally took the air box completely off and noticed that the hose going to the airbox was wrinkle inside and possibly letting air in. I figured I would permatex it up as a temp fix before purchasing that. Well, while it was setting up over night, I decided to run the bike. It ran damn good. It would rev to full throttle even though it was sputtering which I attributed to the lack of vacuum line being connect due to the air box being off. Anywho, I put the air box back on when I got home from work thinking I found the issue and the thing is back running the way it was before. The engine doesn't completely die it just struggles to stay firing. I have also already tried disconnecting the rev limiter (black wire) but got the same results. Does anyone have any other ideas before I take this thing down the road and run it into the Quarry?!?!?!? Thanks
  6. Hi all, I bought this ATV not running, and while doing the leak down test found air leaking from a hole above the exhaust port on the cylinder head. Does anyone know what this hole is connected to? I have a repair manual, but it does not state anything about it. Could it be a part of the auto compression release mechanism? Any help would be much appreciated. Thanks.
  7. I've got a 1995 Polaris Magnum 425 4x4. When I rev it up and let off the gas and then rev it up before it gets back to idle it bogs down pretty bad. It does not idle very long at all before it dies. I've changed the spark plug and cleaned the carburetor 3 or 4 times and soaked it, rinsed it and blew out all passages with compressed air and still have same problem when I put everything back together. Also, a few minutes after I crank the 4 wheeler, gas starts coming out of the drain at the bottom of the carburetor with a fast drip. I thought the gas might have been somehow going through/around the drain screw so I bought a new drain screw and it's still dripping. After I kill it, gas still leaks until I shut fuel line off. Was also wondering if any parts off a 2000 Polaris Scrambler 500 would fit on the 95 magnum. Any information or advice would be very much appreciated. Thanks!
  8. Good morning! Ok I have a 2000 Polaris 425 Expedition 4x4 that was obviously sunk in a pond or creek of mud. Then it was set aside for the past decade. It was given to me. I have cleaned up everything and replaced only the battery (so far). It will run for for only a few seconds before it runs out of fuel. The gas tank had about 2" of mud in the bottom of it. the carb and fuel pump were full of mud. Even the motor had water in it and it has been flushed with oil several times to now it has good oil only in it. All has been cleaned and seems to be working fine...except maybe the fuel pump. People have told me that the fuel pump works off of pressure and therefore if everything is there and operational it should be working. I can remove the inlet fuel line from the pump and let it drip directly into the outlet fuel line leading to the carb. The ATV starts and runs for 10 or so seconds until the fuel runs out. I can do this over and over and it runs over and over. Hooking it up to the fuel pump causes it to not start. It turns over but doesn't start. I think it has something to do with pressure - so I tried pushing compressed air in the tank to force the pump to initiate - and it will spudder etc but never completely start. I even put on another fuel pump (from a riding lawnmower) and it wouldn't start (possibly too small of a pump). I am about to buy a new fuel pump but everyone says they don't know how the fuel pump could be bad.... Any advise?
  9. I have a 96 polaris 425 magnum 4x4. I traded for it without knowing a whole lot about it. It was wrecked hard enough to take the radiator out. They replaced the radiator, rode for roughly 5-10 minutes and it died. They never got it to run again. I started off with no spark. Stator wouldn't test out, it had a bad bobbin. Bought new stator no change. New coil, wire, boot, plug, no change. New CDI, regulator things started changing. I don't know if wiggling wires, just changing parts, I really don't know. At times I have a 4th of july spark, at others maybe half spark, and sometimes no spark. It's ran for 5 minutes, and just dies. 15 minutes maybe and dies. It has run up to 30 minutes at a fast idle and dies. But when it dies, its done. The next day it might run, maybe not. It seems to change whenever you mess with it. Does anyone have any ideas what it could be. I would love to ride it, but it would leave me sitting or walking. I've traced wires until I can't see straight. Checked connections looking for corrosion, loose connections, broken wires. I don't know where to go with it now. Any help would greatly be appreciated.
  10. My buddy is offering to give me his 2002 (I think, or maybe 2001) Polaris Xpedition 425 ATV. I told him I would play around with it if I can find some spare time. I know he's beat the crap out of it, but I'm pretty sure it starts and runs. I think it needs some tires, front rack, and lights, and some other stuff. If anyone has any XPedition parts or experience, please chime in here. It'll probably be May before I get it, and if I do, it's be a new project to get it up to speed..I guess we'll see. It pretty much (from what I remember when he used to ride it) looks like:

×
×
  • Create New...