Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

ELKASuspensionCorp

Full Kit Stage 1 + Winch WARN Utility Quad Giveaway

Recommended Posts

Hi Guys!

We thought you might want to participate to our giveaway for Utility Quad!

We are giving away a Full Set of Stage 1 for Utility Quad + 1 WARN Vantage 3000 Winch!

To participate:

SWEEPSTAKE: Win a Stage 1 ATV shocks combo + Warn Vantage 3000 winch | Elka Suspension

Good Luck!

Drawing will be on March 1st.

Also, the Stage 1 kit is offered for only $995 for a limited time!

Informations & Details here: Stage 1 Front & Rear Kit for Sports-Utility Quads | Elka Suspension

Share this post


Link to post
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By RCNY1
      Seems impossible to find a pair of front shocks for my 02 Yamaha Kodiak,newer or older listings are they the same as a big bear ?  Factory are $245 each !!! Any help appreciated 
    • By StolenATV
      This is the information I have on my kids other fourwheeler I dont have a pic of it because I had just got it for them. Just have a pic of the vin plate.
      The post 100CC ASIAN QUAD Stolen appeared first on Stolen 911.
      View the full article
    • By LMI
      I wanted to share an experience and a fix.
      Headed out was following a pole line, was looking for a cross track that may take me to this speckle trout looking spot on a creek.  All paths and semi paths... failed.  Second objective was to reach a speckle trout lake that has been recently stocked... followed 1 trail to dead end, followed second trail to dead end.... while investigating options on foot and the quad idling it died.
       
      It wouldn't start.  eventually it did... and when it did … it was essentially a pinned idle.  activating the throttle did seem to speed it up but it wouldn't knock out of the racing idle.  couldn't put it in gear at that idle speed.  got towed out.
      when I first got the quad, I ran it off a trail and buried it pretty good in the soft snow... eventually winched out.  It wouldn't start.  eventually did and it was fast idling.  not as fast as this last time. but still fast.  it eventually seemed to settle and I got it in gear and by the time I was back to the truck was acting ok.  chalked it up to the bike being at a bad angle in the snow.
      My investigation last year lead to the throttle position sensor TPS.  how to jumper the diag block to see the sensor position on the display,.  I focused on this nearly sure it was a detuned sensor or broken sensor again this time.
       
      I tore down the front plastic and stuck my head into the TPS area to see what I could see.  What I found was that the throttle body assembly had actually come out of the mounting area (not sure what it is called).  the ring clamp was loose I could move it easily.  Hopeful, I tore down the air intake assembly above it (air filter...etc) removed a sensor clip and a hose.
      I backed off the clamp some more and was able to reseat the throttle body assembly.  put some blue lock tite on the clamp screw.  When I was cleaning off the air intake assembly to ensure I dropped nothing down the intake, I noticed the underside of the air intake "box" also had a clamp.  this screw was completely missing.
      I went to the hardware store, bought a metric replacement (brought clamp with me), seated the assembly, settled the clamp blue lock tite that as well... 
       
      quad fired right up, idled normal, idled up without hesitation and dropped right back off.  Cost of solution $3.87 CND for a pack of 5 metric screws.  moral of my story was don't assume an idle issue is a throttle position sensor problem... there are a number of other factors including air pressure, which I believe was my issue.
       
       
       
    • By Finsdad
      Im new to the forum and the quad I just got. I want to change oil in in. Its almost impossible to find anything on-line. I know it takes 10w40 and know the oil filter location. What oil should I use? Is there a cross reference for oil filter. The closest dealer to me is an hour away. I have NAPA close and like the WIX or Napa gold filters. Also is where can I get a Manuel for it? Thanks
    • By David Land
      About 6 months ago I had a new fuel pump, ECM, stator and heaven only knows what else installed on my 05 King Quad.  It has been running great until the other day when I went to get it off the trailer, and it would not start.  Pulled the plug, and it was a little dirty, but not bad, but I put a new one in just for good measure.  Still would not start.  Pulled the fuel line connector underneath and turned on the switch and fuel was coming out, but with little to no pressure.  I turned the switch off and on multiple times to fill up a water bottle with fuel, and the fuel was good.  As it turns out, the fuel pump is out of warranty (go figure).  So, I'm going to put a pressure gauge on it tomorrow and see what it is pumping.  Is there anything else I can check?
      Many thanks,
       
      David
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Racer944
      Hi Folks;
      Has anybody on here installed a winch on a 2003 Magnum 2x4? I am using a Cycle Country adapter plate (only one I could find), but am having a bit of trouble getting it all to fit properly, and am looking for someone that may have done this install and/or may have some pics of the installation.
      Thanks!
      Eric
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By Bwdeaton
      I recently picked up a king quad 700 that doesn't run in the hopes of getting it running by spring. It had been previously taken apart some and a few pieces are missing in the engine, but the frame is complete and in good condition. The motor will need a piston, rings, cylinder, cams, and a few misc parts that are missing. Also the cases will need to be split to remove the pieces of piston that are in the crankcase. The piston blew up at high rpm and did a number on the cylinder so I'm trying to find out if it would be worth rebuilding this motor it buying another engine to swap in. There may be more damage to this engine that I can see so I was wondering how bad the insides of it could be considering it destroyed the piston. I have found a motor for 1200 plus 200 shipping, the only problem is I don't have that much now and I would have to save up a while before being able to afford it. Any suggestions appreciated.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...