Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Twilight228

New Member from MD

Recommended Posts

Good Morning all.  New member from Maryland.  My family, wife +2, recently entered the atv/dirt bike world. 

Weird background:  Farm boy, engineering undergrad, work in the construction industry.

Novice+ mechanical skills.....but well equipped, looking to expand ability.

  • Like 2

Share this post


Link to post
Share on other sites


Welcome to quadcrazy! Here we talk about everything. Quad related or not.

Sent from my SM-N920V using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      On a 93 Kodiak, and I am sure BigBear behind and below the clutch pack sits a claw of a piece. It has a stack of washer bearing washer, claw, 3 bearing plate, then stabilizer fork that sits on a shaft. What does that bad boy do?
    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By Rich1028
      Hitting the Trail this  Morning.
      3 weeks in a row!
      The Wife and I are heading back out to Leota
      http://www.upnorthtrails.org/trails/leota-trail.html
      Why Leota you might ask,and not somewhere new?
      Cause there are lots of trails to ride,and my old ass has to get familiar with the trails so I do not take a wrong turn.
      ...and Yes I already took a few wrong turns...getting better tho.
       
      Have A Great and safe weekend everyone! 
    • By Admin
      We have added a map of the 100 most recent visitors with their locations powered by Google. You can view it under the "BROWSE" section of the site. You can also click on the tacs to view who it is.
      Navigate to the "BROWSE" section, then to "MEMBER MAP" .
      Or click HERE :smile:
    • By StolenATV
      1987 Suzuki LT 80 and 2007 Honda CRF 50 dirt bike stolen out of my driveway on July 4th. Anyone with info that recovers them will get $400 no questions asked.
      Thanks
      The post Suzuki LT 80 Quad And Honda Dirt Bike appeared first on STOLEN 911.
      View the full article
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...