Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Rick534

Polaris Sportsman Remove Rear Rack

Recommended Posts

i want to remove rear rack

Share this post


Link to post
Share on other sites


@Rick534 moved your post made in the manuals topic into this new topic on your issue.

Share this post


Link to post
Share on other sites

It should be simple enough.  Follow the rack bars down to the bolts that hold it in place.  

Share this post


Link to post
Share on other sites

Not always as simple as it appears. Old age and rust can complicate the situation. Take your time and if you snap a bolt don't panic. I've drilled and removed with an easy out. If that doesn't work you can weld then drill and tap. Good luck. 

Share this post


Link to post
Share on other sites


Sorry I forgot to mention step one. Spray the wd40 and pray first. 

Share this post


Link to post
Share on other sites

The last step of the project is a must. Use neverseeze.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ed Zeppeli
      I have some wobble in my right rear wheel. Too much wobble.
       
      So I've torn into it and will need two bearings and two (different) seals. I'd like to get them locally if possible but need to know the number on the sides of the bearings and seals as I don't know that my bearing shop can source them by vehicle model. I'm told they're very common bearings.
       
      Any idea what the numbers are if mine end up being illegible?
       
      Thanks,
       
      Warren
    • By kgrant
      Fixing up a 1998 King Quad 300. The rear brake was locked up, and the owner tried to force it free and snapped the axle.
       
      I disconnected the brake cable, and tapped on the backing plate with a soft mallet to get the brake freed up. When I pulled off the brake drum a bunch of nasty rust water came out.
       
      Once I had the axle out, I popped the boot off so I could see the inner u joint so I could phase/synchronize it with the outer. There was a flat steel disc floating around in the boot, looks like it used to be pressed into the end of the axle. Glad I got that out of there before it munched up the joint.
       
      The book says the yokes should be aligned, I couldn't get mine aligned. They were always 7 degrees off from each other. A bit frustrating, maybe that's within the tolerance limits?
       
      But I got it all back together and it runs great.
       




       
       
    • By Gerry Davidson
      Can anyone help me , I did the rear brake pads and rotor but cant find the brake fluid reservoir.   The front in rite there but cant find the back . 
    • By Venom
      Hi All,
      Hoping someone will be able to help.
      I have a 2006 Kawasaki Prairie 700 with twin Keihin Carbs CKVR D32. The Rear Carb is leaking out the side during cranking. it is not the float bowl overflow. It is on the opposite side of the carb from the diaphragm. 
      I got this bike not running and someone had already messed with it. I took the carbs apart , cleaned and rebuilt. Everything went pretty easy.  It looks like it could be missing a small tube between the carbs but I have all of them listed in the service manual installed. See the pic for where it is leaking from...
      Any help would be much appreciated.. Thanks.
       


    • By anryu451
      I cannot get this drum off, I already have another drum and backplate on order because I've ruined this one trying to get it off. Completely rusted to splines. I cant fit any hub or wheel puller known to mankind onto these lug studs to try and pull it off, I'm really running out of ideas.
  • Similar Tagged Content

    • By Kevin Vlogs
      Does anybody know how to determine which of the 2 key blanks fits my ATV. I have called several dealers, and Polaris and nobody seems to know which key fits which ATV. I thought with the ViN number they could look it up, but apparently not. I hate to spend the money at Polaris for a key blank and then pay a locksmith to cut it, but the locksmiths around me don't have the Polaris keys in stock. I find them on Amazon and places, but I can't tell which key blank is right for my ATV. Any help would be appreciated.
    • By RAYAR
      Something I've noticed with the AWD on/off operation. When AWD switch is in the on position and the AWD light is on (trans engaged), turning the AWD switch off kills the engine. With trans in neutral, AWD light is off, turning switch off does not kill engine. Since I don't have the operators manual yet, I'm wondering if this is normal operation?
      Thanks, Ray
    • By Georgeann Stricklin
      View File 2014 Polaris Sportsman 570 EFI EPS Owners Manual
      2014 Polaris Sportsman 570 EFI and Sportsman 570 EPS Owner's Manual for Maintenance and Safety
      Submitter Georgeann Stricklin Submitted 06/10/2019 Category Polaris ATV  
    • By Georgeann Stricklin
      2014 Polaris Sportsman 570 EFI and Sportsman 570 EPS Owner's Manual for Maintenance and Safety
    • By weblex
      Problem: The ATV starts and runs at idle perfectly. But as soon as I open the throttle, the engine starts to slow down until it stops. On the attached video you can hear the sound of how it works: see video below
      Prehistory: there is a Polaris Sportsman 500 1998, which for about 1.5 years stood in repair, including also replacing CDI with one taken from the same ATV. Finally, the vehicles were on wheels, traveled several kilometers and overheated - forgot to fill the antifreeze Came back home in small moves. The next trip started well, but after 10 km there was a feeling of a small drop in power (even as the vehicle got warm completely) but still drives. Next trip - the situation is repeated. The next test of ATV through time and a huge loss of power from the very beginning. The engine sneezes, does not want to go more than 5 mph.

      What has been done: the carburetor has been replaced with a new one (inexpensive, $ 40), a new spark plug, a new ignition coil, the engine head has been removed, the piston is in good condition, valves were corrected - but the problem was definitely not in them.

      Ignition control unit is suspected. Who faced similar? Please help in solving the problem.
      Thanks in advance.
       
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...