Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Asen_77

New Yamaha Rider from Bulgaria

Recommended Posts


Happy Star Wars day to all True Fans

 

Hope you will like my small video especially for 19-th December - official premier day of last episode of the Saga!

Wish you great Christmas holidays with all your friends and family :)

Share this post


Link to post
Share on other sites

This year will start with videos from ride with two friends - Mitko with CFMoto 520 and Trajan with Honda TRX 300.

Still not snow but lot mud cover us ^^

 

  • Like 1

Share this post


Link to post
Share on other sites

This week Group has become bigger

CFMoto 520, Yamaha Grizzly 450, Polaris Sportsman 800, Polaris Sportsman 500, Honda TRX300, Kawasaki KFX700 and of course Yamaha Raptor 700R. 

Share this post


Link to post
Share on other sites

Bigger group and bigger fun. First real snow ride for this year :)

 

 

Share this post


Link to post
Share on other sites
On 2/6/2020 at 1:09 PM, Asen_77 said:

Little power on the snow 😜

 

 

THX for posting !!Sweet video keep post em !! 

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, Asen_77 said:

Thanks quadnut20 . Posting every Thursday on schedule :) 

Kool Ill check it out !! 

 

Share this post


Link to post
Share on other sites

This week with can-am Maverick and the Group we made Donuts and ride on the Snow field.

 

Share this post


Link to post
Share on other sites
7 hours ago, Asen_77 said:

This week with can-am Maverick and the Group we made Donuts and ride on the Snow field.

 

Man thats badass THX for posting !!

  • Like 1

Share this post


Link to post
Share on other sites

Another video from our Group :)

Hope you enjoy and will support my channel with subscribe! Thanks to all subscribers :)

 

Share this post


Link to post
Share on other sites

With the group we are going much further away and exploring new areas :)

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JJ78
      I have a yamaha big bear 400, tested all fuses and relays. When I turn on key I get nothing, no neutral light or headlights. Could it be the key switch bad?
       
    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By Blenderite
      Hello guys! New to the forum, and fairly new to ATVs. I've driven them, but never owned one. Now I do own one. Just picked it up today. It's a 1999 Yamaha Big Bear 350. It's been through some stuff. The guy I got it from told me the previous owner removed the front diff because he didn't want to replace the half shaft. So it's 2wd, even though it's supposed to be 4x4. Lovely. I can deal with that for now.
       
      More importantly, I need to get it running. The carb needs to be rebuilt. The guy I got it from said he sprayed it all out and it still didn't work. I'm concerned he might have damaged it or not put all the parts back. I was looking at a replacement carb, and the OEM parts is $600. I'd rather not spend $600 if there are any other options. I have seen carbs on Amazon and eBay that are in the $40 - $100 range that say they fit. Anyone have experience with these? I'm going to get a rebuild kit for the current carb just to make sure that won't fix it.
       
      Thats the first thing with it. Secondly, it was completely rewired. I need to find a original wiring diagram so I can put it back how it was, with a key and all. Currently it's wired with just a rocker switch. Any sources for a service manual that would include wiring diagrams?
       
      Thirdly, is the Big Bear 350 a good atv? I picked it up for $700. It does start and run when you spray starting fluid into the air intake, so I am not concerned about the engine being bad. I plan to use it for the farm, running around and carrying things with it like minerals and feed and such. Not really for mudding and things like that. How good is the 99 350?
       
      I am certain I will have more questions as I examine it more, but that's all for now. Thanks in advance for the assistance!
       
      -Blenderite
    • By jolio
      Just got a '98 Yamaha big bear 4x4 in working condition (so far). Looking forward for some good information on this site about how to keep it alive.
    • By Spike976
      So I dug my warrior out of storage replaced the carburetor with one off Amazon & it was running great. Last week it didn't want to start it would crank & I could smell gas but nothing. I replaced the starter,stator,solenoid,spark plug & coil & resistor but still not starting. Checked the stator and its at 30 ohms tried using starter fluid but nothing. I am completely lost and could use some help thank you
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...