Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Asen_77

New Yamaha Rider from Bulgaria

Recommended Posts

Hi All,

My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

452382133_QuadYamahaRaptor700R.thumb.png.07918305fc96bcdf3f84aaecb932fc38.png

 

  • Like 1

Share this post


Link to post
Share on other sites




And one more video with my Nephew who rides my Quad. He is only 9 years old :)

 

Share this post


Link to post
Share on other sites

New summer ride this week into Green Forest :)

Thanks to All Subscribers for the support!

Edited by Asen_77
  • Like 1

Share this post


Link to post
Share on other sites


This week video is from a Spring season. Just summer time vacation at this moment and schedule need to be followed :)

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

This week video is part 1 of my co-driving with my friend Mitko with CFMoto 520L. We have a very nice day with about 80 km trails this day!

 

 

 

In part 2 there will be additional drone footages ;)

Share this post


Link to post
Share on other sites


I want to show my first video that I uploaded to my channel.

 

Soon I will upload a video on the same trial, but done just now at summer season :)

Share this post


Link to post
Share on other sites

This week second part of my co-driving with my friend with CFMoto 520L. Enjoy :P

 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By spock58
      I was reading another forum recently about fuel leaks and possibility of fire happening. Reminded me of an incident I had a few years ago while working at a Can Am dealership. The quad was a stolen & recovered Outlander 650 that had been tampered with. These quads have an electronic safety system, similar to their DESS system on the sleds. You cannot bypass the key switch and get spark without a computer with factory software. Anyway, I was trying to determine what was damaged since the thief had attempted to hot wire various electronic parts. I got all the extra wires removed and things looked back to stock. Pulled the spark plugs and was going to check for ignition and if the starter still worked. Well, they both worked alright and guess what - the cylinder was flooded with fuel! Instant flames with gas spraying all over...great!! I managed to use my hands to put out the fire, good thing I had on gloves (but choked they were ruined of course, haha). Seems it's possible to flood an engine with efi when you put power straight to the injectors, doh! As in much of life, you cannot take things for granted (I'd only seen carbs flood like that). And even though it had spark, the quad still needed a new ECM to run - that part alone was $1200. So lets hear your stories, crazy stuff happens every day I'm sure.
    • By HeWasRidinDirty
      This 700 was run out of oil. Seized the con rod to the crank....yada yada. So, I rebuilt the engine and now it will start and run for about 5 seconds and die. I replaced the fuel pump with a cheapie from ebay and it didn't change. I replaced the O-rings on the injector and still didn't change. So, the tech at the Yamaha shop said that the most likely problem is the cheapo fuel pump. I got another more expensive one and it still didn't change things. I asked him where the power to the injector comes from and he said the CDI box. But since the thing does run a little, he  ruled that out. Any thoughts?????
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By John conway
      My quad will start sometimes than just die well it’s running than won’t start again for a day , put in new battery same problem and it seems to drain battery any help would be great
    • By raybob
      looking to buy good used carb for suz 500 quad master, I got one from china it is junk let me know if you have one and price. thanks Raybob
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...