Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2007 Arctic Cat 500 LCD Display Problems

Recommended Posts

Hi I was wondering if I could replace my 2007 500's LCD Display with a 2007 700's display, would there be any problems, would it fit, my 500's LCD display is not working properly only a 1/4 of it is working. I would greatly appreciate any help you can give thinks or any good alternatives

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Robin442
      Hello all! New to the site, I came here seeking answers as I've decided to help my cousin get his once good running buyou 220 going again.
      I've owned an 82 kawasaki kz1100 and have done lots of work to it over 20 years of ownership. 
      Looks like the wire diagram colors are same or similar to my bikes wiring, a definite plus
      Cousin was riding through fairly high weeds and brush after it's rained, when it just died. It would turn over but no fire.
      This to me sounds like perhaps a CDI issue or a fried coil, idk that why I'm asking you gurus LOL
    • By spuukii
      Hey everyone, recent new-to-me ATV owner/rider.

      I have a 2003 Bombardier 650 4x4 Quest and recently my speedo just decided to stop working. The odometer doesn't tick up either but that makes sense considering it thinks I'm going 0mph all the time. I found some links online that mentioned there was a speed sensor to the right of the oil dip but after taking it apart I didn't see anything that looked like what Google images says a speed sensor would be.

      The speedo itself moves to 0mph from the off position when turning it on, the backlight for the speedo turns on, and I can switch between trip mileage and hours. The machine itself rides fine as far as I can tell with no bad effects from it. I tried to find a service manual online but it linked me to a bunch of shady sites and I wasn't trying to get scammed out of $15 each until I find one that is actually legit.

      Has anyone had a similar issue and knows what the fix would be, or where I should actually be looking for the speed sensor? Or at least point me towards a reputable site for a service manual that might better explain where/what to look for?
    • By Werewolf
      My wheeler originally had a fuel leak.But on trying to start it no spark. Took front end off, when I try to start it I get one spark then nothing. Come back a while latter one spark,replaced coil and cdi box no help?
    • By jeff1
      Can anyone tell me how to set the parking brake? I can’t figure it out there seems to be a lever on the hand brake but there is no way to engage it into anything. Don’t know if maybe something is missing. Any help would be appreciated.
    • By Jd101506
      Hi all! 
      So I’ve got a early model (86? Maybe?) (slide carb)Suzuki Quadrunner I’m working on. I’ve having a series of really wild fuel problems and I’m hoping someone could point me in the right direction. 
      So when I first got it the fuel pump and carb were both toast. Rusted, awful, unrebuildable messes. So I bought a pair of cheap Chinese ones of eBay and worked on the rest of it. 
      Carb arrives first. I install it, hook a battery up, mainline some fuel into the carb and it runs. Sounds great actually. Ok, cool, runs good, I’m fine. Wait a few days and the fuel pump shows up. Install and the quad runs like absolute dog crap. It would hesitate, stumble, stall, the works. It does sit and idle and start up quickly though. So I assume it’s the fuel pump, so I end up saying screw it and I buy an OEM one. 85$. Meantime I can still get it to run well with drip feeding it fuel. 
      New pump comes in and installed. Same thing. It stumbles, acts like it’s dying, may stall, etc. This new pump is an OEM Suzuki so my assumption is it’s fine? 
      I ended up swapping the carb wondering if the float or something is actually my problem. This is a different carb, a WELL REVIEWED Kipa carb from Amazon. I install that and I have a whole different set of problems… this carb will run at mid to high RPM, idle adjustment screw be damned. All the way in or all the way out it runs at the same RPM. I ended up taking the main slide and needle out and I swapped it for a different one and the RPM dropped. Not a lot but a little. So I try and drop the carb needle as low as I can and it’s still funky. Something isn’t right. 
      So after swapping that carb again I end up rebuilding the Mikuni carb from my Suzuki lt300, and swap the jets over from the Quadrunner rebuild kit I had ordered. Put that carb in and it does the same stupid high idle. I take the choke cable off the bike entirely and it makes no difference and the throttle cable has plenty of slack. As I’m standing there staring at it, it just suddenly drops the idle and sits there idling pretty happy… so I climb on, and it has the same annoying jerky, slow throttle response that the first eBay carb had. 
      So to recap:
      1x Kipa fuel pump kept pushing way too much fuel in. 
      1x OEM Suzuki fuel pump made the carb from eBay smoke like crazy and idle adjustment did absolutely nothing. I could go a full 2 turns from the stock setting of 1-3/4 turns out in either direction and get the same awful running 
      1x ebay carb worked well on a mainline of fuel right to the carb gravity fed. But runs like dogshit around the yard. Jerky and low idle and smoking on both the Kipa carbs and the OEM carb. 
      1x Kipa carb runs at super high RPM and won’t settle down no matter what I do with the cables or anything else. 
      1x rebuilt mikuni did the same as the Kipa but then randomly dropped rpm to idle and then started running like the ebay carb. 
      So I’m appealing to the brains here. I find it hard to believe I’ve tried this many carbs and such and I haven’t found a working solution. As an aside, I’ve swapped the plug, done an oil change, and done a general inspection. Compression test I haven’t done, and I haven’t adjusted the valves but it starts easily. And runs easily mainlining fuel.
      Sitting in the garage it sounds fine. I’m attaching a video of it running with the eBay carb and the OEM fuel pump. It’s just really weird. It feels like I’m flooding it because when it’s idling I can smell it and there is a little smoke from the tailpipe.
      Ill add more video tomorrow of it running like crap around the yard.  
  • Similar Tagged Content

  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...