Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Just wanted to start this thread and wish everyone in the community a happy and safe Labor Day weekend filled with relaxing days off and quad riding!

Have a safe Labor Day weekend!

labor_day_2001.jpg

Share this post


Link to post
Share on other sites


HAPPY LABOR DAY TO YOU TOO, AND ITS A DOUBLELY GOOD WEEKEND FOR ME, DONT HAVE TO WORK(AND I GET PAID) AND ITS MY BIRTHDAY TOMOROW(3RD), BUT ENJOY THE WEEKEND :smile:

Share this post


Link to post
Share on other sites


Reviving a 2 year old thread and wishing everyone a safe and happy Labor Day! Hope everyone had a great weekend!

Share this post


Link to post
Share on other sites


Nothing like reviving and old post...I love it!!! Wishing everyone a happy and healthy Labor Day Weekend! Hopefully some of you are going to be able to get out there and ride.

labor-day-comment-10-701884.gif

Share this post


Link to post
Share on other sites

I am hoping to go riding Sunday or Monday. It is going to be in the 70s here tomorrow cannot wait.

Share this post


Link to post
Share on other sites

I just finished cutting my 1 acre lawn, which I have not cut in almost 2 months due to drought...I'm freaking winded!!LOL.. Tomorrow going to some friends in Long Island and hopefully to the beach one last time on Monday...:biggrin:

Share this post


Link to post
Share on other sites


I just finished cutting my 1 acre lawn, which I have not cut in almost 2 months due to drought...I'm freaking winded!!LOL.. Tomorrow going to some friends in Long Island and hopefully to the beach one last time on Monday...:biggrin:

You need to turn that acre of grass into an acre of dirt and mud, so you can ride on it instead of mow it.:yes:

Share this post


Link to post
Share on other sites
You need to turn that acre of grass into an acre of dirt and mud, so you can ride on it instead of mow it.:yes:

That would be cool..But then I would be sleeping next to that track also...:laugh:

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Daniel Gibson
      Working on a bayou 220 that has been ran extremely hard it's whole life. Literally had almost an inch thick dirt/oil covering the motor. Yeah that bad. Surprisingly it runs though. I cleaned the carb and tank multiple times. They're clean enough to eat off of. Readjusted valve lash and set timing. Was about 3 teeth off. It cranks good and runs good only problem is I have to cover the carb intake basically choking the hell out of it for it to start. The com choke works fine. It does this each time I start it regardless of temperature both ambient or motor. Wth? Compression is at 115psi I get 130s if I put a little oil in the piston chamber. Please help. Thanks 
    • By Mike Johnson
      Does anyone know what the 3rd item is behind the battery on this ATV ? I know 1 is the,  solenoid1 is the CDI box, what is the 3rd.
    • By chriscris
      Any areas? Any suggestions? 
      Thanks
    • By JC4x4
      My Honda Fourtrax won't start. The starter is kicking the engine over, but it won't start. It sat for about a year while I was living away, so I thought it might have been bad gas. I completely drained the fuel, flushed the fuel lines and filled it with fresh gas. However, still nothing. It started and ran fine the last time I used it. Any suggestions on how to diagnose this? It could be fuel or electrical at this point. Is there an easy way to rule one or the other out? Thanks
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...