Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2007 sportsman 500x2 Shutting Off loosing all power


Recommended Posts

unit was shutting off at times n at times running well now runs min or two and shuts off n then power comes on n off with unit setting still can send power to yellow power wire feeding ignition switch n jump across started sol n start n run unit as long as u keep power on the yellow wire n soon as u remove power unit shuts off i've replaced bat. check bat conections checked all wiring for rubbin or shorts checked pin drag at control module and power feeding it check main ground removed n cleaned to be sure was good ....ne sugestions??? control module??:realmad:

Edited by johntdunn3rd
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Jd101506
      Hi all!  
      I've got a 1988 LT4WD that I am working on.  It sat for almost two decades in a shed, so I replaced both the carb and the fuel pump (Pump was rusty, carb was ok, but had a pin hole in the bowl itself?).  Now, I went el cheapo and I replaced BOTH with Chinese aftermarket Carb and Fuel pump.  Now is where it gets confusing:
      So I did this SAME thing on my other Quad, a 1988 LT300E.  They take the same PN carb, and a similar fuel pump, (One has a 90 degree bend in the vacuum port).  I've been battling the four wheeler a bit with some electrical issues, but I noticed that at idle it runs GREAT when I gravity feed fuel from a burp can into the fuel bowl of the carb... But as soon as I put it on the fuel pump from the tank, it idles EXTREMELY low and smokes a little.  To me, this indicated that the carb itself was running rich.  I adjusted it a little on the LT300e, but I could never seem to get it right, it still will slowly die at idle when warm, but ironically if I CHOKE the motor, it'll start up and run.  I dont know if this is because the RPM increases?  But the quad will run around the yard great at RPM and then die at idle.  
      Now, the LT4WD.  I ended up with a faulty fuel pump for my second (I think the spring isn't seated inside as I can hear one rattling around) so when I installed it it WOULD NOT pump fuel.  So I ended up swapping the LT300 pump onto the LT4WD.  Boom, pumps fuel.  I put it all back together and got my tires on.  I ran it around my yard and it exhibits the SAME symptoms as the LT300e!  It will run around at RPM, but it will not stay running at idle, it drops realllllly low RPM and will start smoking a little as if its running rich.  Again, when I ran it with the fuel pump OFF I didn't have this issue. 
      In my head I'm thinking it would be a mixture screw OR float issue... But the mixture screw doesn't seem to help me on either, and the bowls are not over flowing (I checked both overflow lines).  Is there something I'm missing here thats obvious?  Is there a vacuum line or something I missed? Maybe some configuration or something I missed? I reviewed the manual and nothing stood out to me.  
      Conclusion:  Two different Suzuki fourwheelers, two different carbs (Both are chinese Ebay carbs) that BOTH run well when I mainline fuel from a drip can INTO the bowls, BOTH do not keep idle and seem to run extremely rich as they run great at RPM but slowly die at idle.  Adjustment screws, idle screws be damned.  
      I ended up ordering a new Suzuki OEM fuel pump for ~90$ just to have it and see if it makes a difference.  Any advice here though would be SUPER appreciated!  
    • By FalloutBoy
      I can't find a diagram for my Can-Am, all the diagrams have different color coded wires and are missing the necessary parts to fully re-wire my Can-Am.     Any help would be appreciated 
    • By Whiterabbit
      Hey all, from SW Virginia here. I just picked up a '01 Bombardier Quest 650 on the cheap (seller couldn't get it to start). After correctly plumbing the fuel pump (new pump the prior owner installed but had the hoses going backwards lol) and cleaning the carb and fuel tank, repaired all the batt - and batt+ connections she lives!!  I had swore to the wife unit I wouldn't be dragging another "project" home but I couldn't pass it up, it had new tires, new starter, new fuel pump and low hrs. All's good after she took it for a ride! 😆 It rides like a tank, very stable and tons of power.
    • By Wonderwoman
      I am hoping that someone here can give me some more ideas. Our poor old red 300 won't start. We rode it, running fine, shut it off and now it won't start. Have gas to the carb and spark at the plug. Valves are adjusted. Still won't start. Tried a little starting fluid in the air chamber and still won't start. This poor old machine has 7000 miles on it. That has to be an Arctic Cat record! And I have never touched the engine besides setting the valves. Unfortunatly it looks like it only has 60 psi of compression. Don't understand how it could be running fine and then nothing. Someone give me a clue as to what I am missing or what to check. I was going to rebuild the top end this next spring but didn't want to do that this winter in a non-heated garage. Any help?
    • By Sonders
      I purchased a super clean 07' Sportsman 800 EFI last year from the original owner with around 700 miles on it,  The only thing I haven't liked about it since purchasing was the aftermarket twist throttle they had installed on it.  They had it set up for running up and down the road, which was fine for them; but I needed it for a workhorse around the house pulling a bush hog, log splitter and wagon loads of wood.  Twist throttle doesn't work too well for my applications.  I purchased a oem thumb throttle and cable and installed yesterday.  After install the quad will start right up and idles perfectly, but as soon as I give it some throttle it sputters and tries to die.  Can bump the throttle hard and fast and it will go, but it tries to sputter still.  It's like older style carb that has junk in the fuel line or not getting enough fuel, however I didn't touch anything on it, other than disconnecting the aftermarket cable from the carb and connecting the new one.  I checked the points inside the thumb throttle control box (forgot actual name) and they are gapped, so they're not killing it.  The only thing I can think of is the throttle position sensor had to be unbolted and pulled off the carb so I could remove the entire carb assembly to gain access to the side of it to remove side cover and unhook old cable and hook up the new cable.  I installed it back the exact same way it came off, but could that somehow still have gotten messed up?  I have no clue what else to check as I'm not real familiar with these EFI set ups.  Any thoughts/help are appreciated.  Apparently I should have just left it alone and lived with the dumb twist throttle as it was running perfectly fine. 
  • Similar Tagged Content

  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...