Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

CK1999_400ex

What does your quad weigh ?

Recommended Posts





I have an 01 polaris scrambler 500 2x4 i think the dry weight is 523 lbs ya it is its on the manual but my quad probably ways a little bit less has a rear rack that is meant for like a cooler a 6 pack rack which is lighter than what came on there and have a fmf muffler which is significantly lighter than those heavy stock polaris mufflers i call them water spouts because it looks like something water or coffee would come out of but then again i did add a 7 inch light bar that about 5 pounds added a k&n filter 1 pound heavier lol just kidding its lighter than it was stock which is good because these are heavier quads.

Share this post


Link to post
Share on other sites




My Honda ATC 250SX has a dry weight of 357 Lbs. 

Our Honda Recon ES has a dry weight of 414 Lbs. 

I love light ATVs that you can toss if around easily if you feel like it 😎

Share this post


Link to post
Share on other sites

2001 Xplorer 400L > 570 lbs dry.

1996 Sportsman 500 > 649lbs dry.

1998 Sportsman 500 >660 lbs dry.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By oxidized_black
      these are what i have in my collection ... always looking for more
      1985 - 1995 Polaris All Models Service Manual
      1996 - 1998 Polaris All Models Service Manual
      1996 - 2003 Polaris Sportsman & Xplorer 500 Service Manual
      1996 - 2003 Sportsman 400 & 500 ~ Xplorer 500 Service Manual
      1999 - 2000 Polaris All Models Service Manual
      2001 Polaris 90 Service Manual
      2001 Polaris Scrambler 50 ~ 90 Sportsman Service Manual
      2001 Polaris Sportsman 500HO Parts Manual
      2001 Polaris Sportsman 500 Parts Manual
      2002 - 2003 Polaris Sportsman 600 & 700 Servive Manual
      2002 Polaris Sportsman 700 Service Manual
      2003 - 2005 Polaris Magnum 330 Service Manual
      2003 Polaris Predator 500 Service Manual
      2003 Polaris Predator Parts Manual
      2003 Polaris Trail Blazer 250 Service Manual
      2003 Polaris Trail Boss 330 Service Manual Part I
      2003 Polaris Trail Boss 330 Service Manual Part II
      2003 Polaris Trail Boss 330 Service Manual Part III
      2004 Polaris Predator 500 Owner's Manual
      2004 Polaris Sportsman Owner's Manual
      2005 Polaris 400 & 500 Sportsman Service Manual
      2005 Polaris 700EFI Owner's Manual
      2005 Polaris 800EFI Owner's Manual
      2005 Polaris Sportsman 400 Parts Manual
      2005 Polaris Sportsman 500 Parts Manual
      2005 Polaris Sportsman 6x6 Owner's Manual
      2005 Polaris Sportsman 700EFI & 800EFI Service Manual
      2005 Polaris Sportsman 800 Twin EFI Parts Manual
      2006 - 2007 Polaris Outlaw 500 Service Manual
      2007 Polaris 700 800 800x2 EFI Service Manual
      2007 Polaris Ranger 700EFI 6x6 Parts Manual2007 Polaris Ranger 700 4x4 & 6x6 Service Manual
      2007 Polaris Ranger XP 4x4 Service Manual
      2007 Polaris Sportsman 450 & 500EFI - 500X2EFI Service Manual
      2007 Polaris Sportsman 700 800 - 800EFI Service Manual
      2008 Polaris Sportsman 500EFI & 500x2 Service Manual
      2008 Polaris Ranger 6x6 700EFI Parts Manual
      2008 Polaris 800 RZR Service Manual
      2008 Polaris Sportsman 700x2 - 800EFI - 800 Touring Service Manual
      2009 Polaris 850HD EPS Service Manual
      2009 Polaris Outlaw 450 & 525 Service Manual
      2009 Polaris Outlaw 90 Service Manual
      2009 Polaris Predator 50 Service Manual
      2009 Polaris Ranger 2x4 Service Manual
      2009 Polaris Ranger 4x4 Crew Service Manual
      2009 Polaris Ranger 500 2x4 Service Manual
      2009 Polaris Ranger 500EFI 4x4 Service Manual
      2009 Polaris Ranger 500EFI 4x4 Service Manual
      2009 Polaris Ranger 700 4x4 Crew Service Manual
      2009 Polaris Ranger 700 4x4 Service Manual
      2009 Polaris Ranger INTL Service Manual
      2009 Polaris Ranger RZR 170 Service Manual
      2009 Polaris Scramber 500 Service Manual
      2009 Polaris Sportsman 300 & 400HO Service Manual
      2009 Polaris Sportsman 450 & 500X2 Service Manual
      2009 Polaris Sportsman 500 Service Manual
      2009 Polaris Sportsman 6x6 800 Service Manual
      2009 Polaris Sportsman 800EFI & 800EFI Service Manual
      2009 Polaris Sportsman 550XP Service Manual
      2009 Polaris Sportsman 850XP Service Manual
      2009 Polaris Trail Boss - Trailblazer 330 Service Manual
      2010 Polaris Ranger RZR S Service Manual
      2011 Polaris Ranger RZR S Service Manual
      2011 Polaris Ranger RZR SW Service Manual
      2012 Polaris Sportsman 400 Service Manual
       
      Visit the Polaris Service Manual Section: https://www.quadcrazy.com/files/category/7-polaris-atv/ 
    • By Joseph Miller
      Hi guys im new here and ive been doing alot of research on my polaris predator i was wondering if anyone on here has wired a different cdi up on there quad? Not a direct replacement that would simply just plug in. I know my white an w/red wires go to my pulsar my green an blue go to my reverse coil but im unsure which is + and which is ground also brown/w is a ground correct? What about purple? Black goes to my kill switch and red is my 12v supply........then ive got yelloww/red , yellow / yellow that goes to my rectifier..........any input on this subject is greatly appreciated thank you all
    • By Boppers
      I recently got a 94 Polaris sportsman 400 4x4 from a family member. It just quit on him and has not run in 5 months. I put new fuel in, cleaned the carb, new plug. There's fuel getting to it and a good spark but it will not fire. It will turn over but will not start and I'm lost. Please help.
    • By Trevor B
      Hello. I got this fourwheeler to fix for my buddy. It wasnt starting at all when I got it so I opened the valve cover up and checked the timing and the timing was way off. I set the timing bolted all back together and it started. It only stays running with very little throttle applied. There is a weird noise coming from the engine and it smells like its burning and also smokes from the headers. I posted a video idk how helpful it will be but I need some advice on the next step. I want to say it's the piston and rings, but I'm not too sure was also thinking something was up with the valves. Thought I would get some advice before trying anything. Thanks!
       
       
  • Similar Tagged Content

    • By Dana Hudson
      Hey everyone, hoping to get some help here... my kids 03 KTF 50 Quad has always ran great... they were riding it a couple of hours a few days ago and it died a couple of times (not normal) but started right back up. A few days later my 5 year old wanted to take it for a spin so I started it (2 pulls) and he took off.. he made it a couple hundred yards and it died and we havnt been able to start it since. I have new gas, good spark and 120 psi compression.. it will not start with starter fluid in the intake or even in the cylinder.. the fuel bowl has fuel at the carb... what am I missing? It’s driving me crazy!!
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • By johnwayne
      i have a 2000 suzuki king quad lt-f300f that i picked up as a project bike. it didnt run well when it was parked outside 5 years ago. it cranked after putting fresh gas - but would not run below half throttle, i took apart the carb, cleaned debris, and re-assembled. i suspect that the pilot needle is sheared off - it never protrudes into the throttle body through the pinhole. now to get the bike to ALMOST idle, the throttle idle adjustment knob is all the way up/in. the pilot needle is turned almost all the way in/up (if i understand correct, it should nominally be out 2 1/4 turns or so). and like i said, it will ALMOST idle. floods easily, rides rough.
      wanted to hear from those more experienced than me with suzukis - and im self-taught atv repair, so dont laugh too hard if my verbiage/part names is way off. 
      facing the driver's side of the bike [US] there are three hoses on this side of the carb. without a service manual or way of knowing what was messed up before i got it, i think i have them right: front hose as a vacuum to the petcock, middle hose as vacuum to the fuel pump, rear hose as fuel line from the fuel pump. running the bike in prime position results in flooding even while riding. with all hoses disconnected from the carb, fuel slowly drips from the vacuum line connected to the petcock.
      so just my speculation is that the diaphragm in the petcock is split, and the pilot needle is broke off - causing my inability to not quite idle and the rough ride. this suzuki is hoses and cables everywhere compared to the honda ranchers and yamaha warriors i am used to. I would like to have a plan rather than: replace everything at once.
      is my speculation on the right track, or could something else be at play? say, if the compression was non-existent, would that cause non-idling? i am all ears, look forward to the input.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...