Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

fierogary

1997 Suzuki LT 80 Does Not Turn Freely

Recommended Posts

ve a 1997 suzuki lt80 and when i try to turn it's as if the brakes are applied.  it does not turn freely....i dont what to do to correct this...please help with suggestions...thank you

Share this post


Link to post
Share on other sites


ve a 1997 suzuki lt80 and when i try to turn it's as if the brakes are applied.  it does not turn freely....i dont what to do to correct this...please help with suggestions...thank you
What do you mean turn? Like starting or rolling.

Sent from my SM-N920V using Tapatalk

Share this post


Link to post
Share on other sites

Topic moved to Suzuki ATV forum and added full atv and issue into topic title.

Share this post


Link to post
Share on other sites

When you go straight it’s free spinning but when you goto turn it slows fast and seems to bind and hard to go.  On a straight away it’s fine 

Share this post


Link to post
Share on other sites


Lube your bearings. Check your cable routing

Sent from my SM-N920V using Tapatalk

Are your tie rods straight

Sent from my SM-N920V using Tapatalk

Are your tie rods straight

Sent from my SM-N920V using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JustRandy
      After looking at the wire diagram I saw the blue w/black stripe wire is coming from the neutral and reverse lights looking for ground thru the neutral and reverse switches. If it finds ground, the lights come on. The same wire also comes from the neutral relay looking for ground at the same neutral and reverse switches. So it was easy to trick the relay into thinking the engine is in neutral all the time without having the light on all the time. Just cut the blue w/black wire at the relay and ground it. Easy
      Sorry the pics aren't better




      Now it starts in any gear and indicator lights work as they should.
    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By pablo Blake
      Its in pretty rough shape and its gonna be my first atv, I worked on bikes before but nothing to do with quads. Anyways the quad has some problems and im tryna figure out what to focus on first. So the U joints i think are shot. The bike starts first try every time ussually have to give it a lil gas with the throttle and revs right up, idles fine but its running REALLY rich 3 starts and my brand new plug was pitch black

      Bike is L model

      video-1577465068.mp4

      Its using the original mikuni carb but im not the best at fixing the carbs and wondering if there is anywhere online that would be able to either walk me through it or help me with it i didnt see a air mixture screw so it seems like im gonna half to open it up and adjust like the float and a couple other things
    • By Jerry Hebert
      1985 Lt50 no spark from aftermarket coil . Are these Suzuki coil specific ??
    • By flyinbrian365
      View File 1987-90 Suzuki LT 500R Quadzilla Service Manual
      1987-90 Suzuki LT 500R Quadzilla Service Manual. Full version clear pages
      Submitter flyinbrian365 Submitted 07/21/2020 Category Suzuki ATV  
  • Similar Tagged Content

    • By nix377
      Friend of mine picked up an LT80 that needs some work. The manufacture date is 11/1986
      The fuel and vacuum lines for the carb were all disconnected. I picked up a new card and was hoping someone on here has a photo or knows how the lines are hooked up
      Thanks in advance
    • By shar
      Picked up an LT80 (unknown year) for $200 recently for my girls. Not running at the moment, but does turn over. I’m thinking the carb needs to be rebuilt or replaced, as it appears to be leaking 2 stroke oil. Anyway, I’m excited to have something to wrench on in my (limited) spare time






    • By Admin
      View File 2002-2006 Suzuki LT80 Service Manual
      2002-2006 Suzuki LT80 Service Manual
      Submitter Admin Submitted 06/29/2019 Category Suzuki ATV  
    • By Admin
      2002-2006 Suzuki LT80 Service Manual
    • By Admin
      1996-2001 Suzuki LT80 Service Manual
      View File 1996-2001 Suzuki LT80 Service Manual
      Submitter Admin Submitted 06/29/2019 Category Suzuki ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...