Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

G'day all,

just sayin howdy and to introduce myself, Name is Garth, 38 with two kids (9 & 4 months) live in darwin australia, i own three quads 2 raptors(2011 700 & 2003 660) and a suzuki ltz90(my daughters) havent ridden for about 20 years so have a bit of catching up to do:australiaflag:

Share this post


Link to post
Share on other sites






Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Shawn Hurt
      I have a 2013 KQ I bought it new but rolled it a few years ago. I have replaced the left lower A-arm and left tie rod, the steering is still a little sketchy as I just eye balled the alignment. But the major issue is the left front tire cambers out at the top and has wore the tire bald. Tires have about 2000 miles on them but other 3 are half tread and left front is a slick.. I can not see anything else bent and don't know what to do..  
    • By HeWasRidinDirty
      I got this 400, that wouldn't start. It would try, but wouldn't catch. I checked the valves and the L intake was tight at .002. The compression came in around 120. It didn't improve after a couple of drops of oil into the cylinder. So,I figured it was the valve causing the problem. So, I got the valves squared away, but it still won't start. I checked the spark and it seems like it's getting an intermittent spark. It fires a few times then nothing. If l let up on the button and then hit again immediately, it will fire a few more times, then repeat. So, what am I looking at as a possibility? Electrical issues are not my strong point. LOL
    • By oxidized_black
      these are what i have in my collection ... always looking for more
      1985 - 1990 Suzuki LT230 & LT250 Service Manual
      http://rapidshare.com/files/3408466380/1985%20-%201990%20Suzuki%20LT230%20%26%20LT250%20Service%20Manual.pdf
      1987 - 1998 Suzuki Quad Runner 250 & King Quad 280 Service Manual
      http://rapidshare.com/files/4183862408/1987%20-%201998%20Suzuki%20Quad%20Runner%20250%20King%20Quad%20280%20Service%20Manual.pdf
      1987 - 2006 Suzuki LT80 Service Manual
      http://rapidshare.com/files/2550473580/1987%20-%202006%20Suzuki%20LT%2080%20Service%20Manual.rar
      1987 Suzuki LT500R Quadzilla Service Manual
      http://rapidshare.com/files/4261907986/1987%20Suzuki%20LT%20500R%20Quadzilla%20Manual.rar
      1988 - 1992 Suzuki LT250R Porting Instruction
      http://rapidshare.com/files/2211227601/1988%20-%201992%20Suzuki%20LT%20250R%20Porting%20Instruction.pdf
      1988 - 1992 Suzuki LT250R Quadracer Service Manual
      http://rapidshare.com/files/2017114826/1988%20-%201992%20Suzuki%20LT%20250R%20Quadracer%20Service%20Manual.pdf
      1988 - 1992 Suzuki LT250R Tuning Guide Instruction
      http://rapidshare.com/files/2646189275/1988%20-%201992%20Suzuki%20LT%20250R%20Tuning%20Guide%20Instruction.pdf
      1999 - 2004 Suzuki King Quad 300 Service Manual
      http://rapidshare.com/files/4083575866/1999%20-%202004%20Suzuki%20King%20Quad%20300%20Service%20Manual.PDF
      2002 - 2007 Suzuki 500LTA Service Manual
      http://rapidshare.com/files/117478118/2002%20-%202007%20Suzuki%20500%20LTA%20Service%20Manual.pdf
      2002 - 2009 Suzuki LTF250 Ozark Service Manual
      http://rapidshare.com/files/487503898/2002%20-%202009%20Suzuki%20LTF%20250%20Ozark%20Service%20Manual.pdf
      2003 Suzuki LTZ400 Service Manual
      http://rapidshare.com/files/158558615/2003%20Suzuki%20LTZ%20400%20Service%20Manual.rar
      2006 Suzuki 50LTZ Quad Sport Service Manual
      http://rapidshare.com/files/4135680547/2006%20Suzuki%2050%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
      2004 Suzuki 250LTZ Quad Sport Service Manual
      http://rapidshare.com/files/1048588852/2004%20Suzuki%20250%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
      2005 Suzuki LTA700 King Quad Service Manual
      http://rapidshare.com/files/1790653344/2005%20Suzuki%20LTA%20700%20King%20Quad%20Service%20Manual.pdf
      2007 Suzuki 90LTZ Quad Sport Service Manual
      http://rapidshare.com/files/4042730335/2007%20Suzuki%2090%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
      2008 Suzuki 400FLTF King Quad Service Manual
      http://rapidshare.com/files/3004786025/2008%20Suzuki%20400F%20LTF%20King%20Quad%20Service%20Manual.pdf
      2008 Suzuki 750 King Quad Service Manual
      http://rapidshare.com/files/630050962/2008%20Suzuki%20750%20King%20Quad%20Service%20Manual.pdf
      2009 Suzuki 400LTZ Quad Sport Service Manual
      http://rapidshare.com/files/3513183033/2009%20Suzuki%20400%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
       
      ALSO CHECK SUZUKI ATV SERVICE MANUAL DOWNLOADS
    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By Tahj
      I bought a 2003 Recon from a kid that beat it – all plastics cracked etc, When I replaced the rear brake the inside – axle, rear oil  - were clean and in good shape, so I think Honda won the kid vs quad battle.
      It shifts a little clunky (I made the adjustment) and after riding for a while I get a hot friction material smell I wonder if he used the wrong oil and if any damage was done.
  • Similar Tagged Content

    • By dubs
      I am new to this forum and dont know how to post a question , maybe im already in the right place. I have a 2001 warrior 350, runs great but will not shift in to gear, when i do get it to shift it acts like it wants to go but does nothing. Even with it off and in 1st gear it rolls easy like its not engaged, any help???? thanks
    • By ironeaglejtwells
      Hello fellow rider;
      My Names is James. I am stationed in Ca. I am new to the sport. I own a '07 Polaris Sportsman 500x2. Looking forward on going on my first trail ride w/the new quad this weekend.
      -Ride Safe!!!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...