Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.


Photo Information for my lil man with my latest toy


Recommended Comments

my little guy likes to go for a short ride now and then, my daughter not so much, she says the quad is too loud

Share this comment


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Dana Hudson
      Hey everyone, hoping to get some help here... my kids 03 KTF 50 Quad has always ran great... they were riding it a couple of hours a few days ago and it died a couple of times (not normal) but started right back up. A few days later my 5 year old wanted to take it for a spin so I started it (2 pulls) and he took off.. he made it a couple hundred yards and it died and we havnt been able to start it since. I have new gas, good spark and 120 psi compression.. it will not start with starter fluid in the intake or even in the cylinder.. the fuel bowl has fuel at the carb... what am I missing? It’s driving me crazy!!
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By Jason Magnone
      As stated above working on a 1999 Suzuki LT-F160. I think I’m having trouble with the carburetor. I keep fouling spark plugs. Full disclosure, I did make a poor attempt to “rebuild” the carb (that’s why I think that’s the issue). No idea if the new parts are at the correct “settings” (gaps and such) I believe the starting point is 1.5 turns from bottom out on the adjustment screw (is there another adjustment I don’t know of?).  Doesn’t feel like I’m getting gas drawn through the carb (clogged jet maybe?), the plug isn’t wet at all (assuming why they’re fouling?) Not a great deal of experience working on carbs and not having much luck on finding a lot of info on the 160’s.
      1st- by chance can I swap out the original carb (13200-02C03) for an LT 250 model (think the HA01050). They’re only about $30 apposed to $200. That would at least narrow down if it’s a wiring problem or carb issue.
      2nd - The wiring has been minipulated at least a dozen times (before I acquired it, my cousin got it from a buddy kind of thing). Hopefully don’t have to dig into this too much as it’s currently a bit if a mess. 
      I was told it ran last year... 
      Any imput would be greatly appreciated
  • Check these out!




×
×
  • Create New...