Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.


Photo Information for Happy 4th of July


Recommended Comments

The fireworks fail video shows howI did it, although it didn't work out in that video LOL

Share this comment


Link to comment

I don't know about a backflip, somebody was messing with my jump and broke my shovel, so I had to go with what they left me. It wasn't the best, so I got a little out of shape here and there   lol.

Share this comment


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Dana Hudson
      Hey everyone, hoping to get some help here... my kids 03 KTF 50 Quad has always ran great... they were riding it a couple of hours a few days ago and it died a couple of times (not normal) but started right back up. A few days later my 5 year old wanted to take it for a spin so I started it (2 pulls) and he took off.. he made it a couple hundred yards and it died and we havnt been able to start it since. I have new gas, good spark and 120 psi compression.. it will not start with starter fluid in the intake or even in the cylinder.. the fuel bowl has fuel at the carb... what am I missing? It’s driving me crazy!!
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • By johnwayne
      i have a 2000 suzuki king quad lt-f300f that i picked up as a project bike. it didnt run well when it was parked outside 5 years ago. it cranked after putting fresh gas - but would not run below half throttle, i took apart the carb, cleaned debris, and re-assembled. i suspect that the pilot needle is sheared off - it never protrudes into the throttle body through the pinhole. now to get the bike to ALMOST idle, the throttle idle adjustment knob is all the way up/in. the pilot needle is turned almost all the way in/up (if i understand correct, it should nominally be out 2 1/4 turns or so). and like i said, it will ALMOST idle. floods easily, rides rough.
      wanted to hear from those more experienced than me with suzukis - and im self-taught atv repair, so dont laugh too hard if my verbiage/part names is way off. 
      facing the driver's side of the bike [US] there are three hoses on this side of the carb. without a service manual or way of knowing what was messed up before i got it, i think i have them right: front hose as a vacuum to the petcock, middle hose as vacuum to the fuel pump, rear hose as fuel line from the fuel pump. running the bike in prime position results in flooding even while riding. with all hoses disconnected from the carb, fuel slowly drips from the vacuum line connected to the petcock.
      so just my speculation is that the diaphragm in the petcock is split, and the pilot needle is broke off - causing my inability to not quite idle and the rough ride. this suzuki is hoses and cables everywhere compared to the honda ranchers and yamaha warriors i am used to. I would like to have a plan rather than: replace everything at once.
      is my speculation on the right track, or could something else be at play? say, if the compression was non-existent, would that cause non-idling? i am all ears, look forward to the input.
  • Check these out!




×
×
  • Create New...