Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Announcements/Support

Official QUADCRAZY Announcements and Support Requests.


137 topics in this forum

    • 2 replies
    • 6.1k views
    • 41 replies
    • 7.6k views
  1. Member Map New Version

    • 15 replies
    • 7.9k views
    • 1 reply
    • 715 views
    • 0 replies
    • 833 views
  2. Updating QUADCRAZY

    • 0 replies
    • 796 views
    • 1 reply
    • 985 views
  3. More Emojis Added!

    • 2 replies
    • 1.1k views
    • 0 replies
    • 716 views
    • 14 replies
    • 3.3k views
  4. Happy Holidays From QUADCRAZY! 1 2

    • 32 replies
    • 5.2k views
    • 0 replies
    • 929 views
    • 0 replies
    • 810 views
    • 12 replies
    • 4.4k views
    • 2 replies
    • 1.5k views
  5. Video Link Embed Corrected

    • 0 replies
    • 1.5k views
  6. Forum Mobile Version

    • 1 reply
    • 1.5k views
    • 0 replies
    • 1.6k views
  7. NEW: Top Member Stats Added!

    • 18 replies
    • 5.6k views
    • 0 replies
    • 1.3k views
    • 3 replies
    • 2.2k views
    • 11 replies
    • 2.7k views
    • 1 reply
    • 2.5k views
  8. Happy Easter Weekend !!

    • 13 replies
    • 3.2k views
    • 0 replies
    • 1.7k views


  • Latest Forum Posts

    • Yes definitely  clean the tank too. Get all the old gas and  any sludge that settled out of it  out .. I  have an  ol tiller that  gas was never drained out of  and it sat for years . There was still liquid in the carb  but a sticky  goo had settled out of it ..  The  seat  for the float pin was plastic and  swollen up as well as jets and passages were plugged .. I ended up  replacing the  carb.   I had to  completely fluch the fuel tank because it also  had that sludge in it .
    • Thanks for the reply.  Do you think it is worth draining and flushing the fuel tank?
    • You're concerned about watts when amps is what you need to figure out. A standard light draws 12-13 amps where an LED of equal lumens draws 2-3 so if you get a 22" light bar it will draw less than 2 headlights and taillights. Watts is how lightbulb lumens are judged for output not draw 
    • Yeah Dave, it's always that low but, when I check my bosses 300 with the same meter it reads 12.35-79 with it running, even swapped coils this morning before work and still no joy
    • That's a strange one indeed. Does the battery read the full 12v + with the motor off and just that lower reading  when it is running?   Turning lights or  other accessories on with that low a voltage  should kill it rather than  make it  run better .. I'm  wondering if  maybe there  is a bad diode allowing AC to  cause false readings on your voltmeter.  What  are the readings with  everything turned off , when   ignition on   but nothing running and   is it always that low a reading with the motor running?  Can't help  more than to  just suggest  those checks  to help you diagnose  or someone more knowledgeable than me  to  use to  help  you diagnose it further .

×
×
  • Create New...