Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Suzuki King Quad Cutaway

Ajmboy


Photo Information for Suzuki King Quad Cutaway


Recommended Comments

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By weblex
      Problem: The ATV starts and runs at idle perfectly. But as soon as I open the throttle, the engine starts to slow down until it stops. On the attached video you can hear the sound of how it works: see video below
      Prehistory: there is a Polaris Sportsman 500 1998, which for about 1.5 years stood in repair, including also replacing CDI with one taken from the same ATV. Finally, the vehicles were on wheels, traveled several kilometers and overheated - forgot to fill the antifreeze Came back home in small moves. The next trip started well, but after 10 km there was a feeling of a small drop in power (even as the vehicle got warm completely) but still drives. Next trip - the situation is repeated. The next test of ATV through time and a huge loss of power from the very beginning. The engine sneezes, does not want to go more than 5 mph.

      What has been done: the carburetor has been replaced with a new one (inexpensive, $ 40), a new spark plug, a new ignition coil, the engine head has been removed, the piston is in good condition, valves were corrected - but the problem was definitely not in them.

      Ignition control unit is suspected. Who faced similar? Please help in solving the problem.
      Thanks in advance.
       
       
    • By Jason Magnone
      As stated above working on a 1999 Suzuki LT-F160. I think I’m having trouble with the carburetor. I keep fouling spark plugs. Full disclosure, I did make a poor attempt to “rebuild” the carb (that’s why I think that’s the issue). No idea if the new parts are at the correct “settings” (gaps and such) I believe the starting point is 1.5 turns from bottom out on the adjustment screw (is there another adjustment I don’t know of?).  Doesn’t feel like I’m getting gas drawn through the carb (clogged jet maybe?), the plug isn’t wet at all (assuming why they’re fouling?) Not a great deal of experience working on carbs and not having much luck on finding a lot of info on the 160’s.
      1st- by chance can I swap out the original carb (13200-02C03) for an LT 250 model (think the HA01050). They’re only about $30 apposed to $200. That would at least narrow down if it’s a wiring problem or carb issue.
      2nd - The wiring has been minipulated at least a dozen times (before I acquired it, my cousin got it from a buddy kind of thing). Hopefully don’t have to dig into this too much as it’s currently a bit if a mess. 
      I was told it ran last year... 
      Any imput would be greatly appreciated
    • By Zacharia Maisonneuve
      i have a 1993 timberwolf yamaha and the compression is good and lights work but for some reason the electricity is not going to the spark plug(s)! i got a friend to check it out and they said its no use but im not giving up! please help with this!
    • By Connor Tuftin
      I have a 1988 300 Honda FourTrax, All wheel drive.
      My brother and I were fixing up this quad. We put a brand new battery and fuses in and it was running fine until we put the quad into reverse. As soon as it was put into reverse all of the electrical cut out and power wasn't making it to the head unit anymore and both of the brand new fuses popped. We figured there might have been a short from the starter or solenoids, but they are all working properly. At this point we don't know where to start looking for where the short could be. I'm just wondering if anybody has had the same issue or knows of similar issues that could cause these electrical shorts?
    • By Resurgence Small Engine Inc.
      Not satisfied with the commercially available versions, Jonathan recently built an ATV spring compressor.
      In this video, he demonstrates using it to remove & re-install the spring on an ATV coil-over shock absorber.
      Mistake in video - the coil-over shock is not quite a McPherson strut.
      If you are inspired to build your own spring compressor, feel welcome to use any ideas from this video.
      Thanks for watching! Resurgence Small Engine Inc.
       
  • Check these out!




×
×
  • Create New...